diff mbox series

[bug#35446,17/26] gnu: calibre: Disable tests that require networking.

Message ID 20190427093659.21851-17-mail@brendan.scot
State Accepted
Headers show
Series [bug#35446,01/26] gnu: Use 'license:' prefix in (gnu packages web). | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Brendan Tildesley April 27, 2019, 9:36 a.m. UTC
* gnu/packages/ebook.scm (calibre)[configure]: set CI=true so Bonjour test
doesn't try to run without networking.
---
 gnu/packages/ebook.scm | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 3f854ce9b3..72d07ea370 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -183,6 +183,9 @@ 
                   "/bin/pdftohtml\"")))
               (setenv "PODOFO_INC_DIR" (string-append podofo "/include/podofo"))
               (setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))
+              ;; This informs the tests we are a continuous integration
+              ;; environment and thus have no networking.
+              (setenv "CI" "true")
               #t)))
          (add-after 'build 'build-mathjax
            (lambda* (#:key inputs #:allow-other-keys)