diff mbox series

[bug#35446,24/26] gnu: calibre: Unbundle python2-odfpy

Message ID 20190427093659.21851-24-mail@brendan.scot
State Accepted
Headers show
Series [bug#35446,01/26] gnu: Use 'license:' prefix in (gnu packages web). | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Brendan Tildesley April 27, 2019, 9:36 a.m. UTC
* gnu/packages/ebook.scm (calibre):
[snippets]: Remove all of src/odf instead of just the thumbnail with the
uncertain license (that was probably free anyway).
[inputs]: Add python2-odfpy.
---
 gnu/packages/ebook.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 993a425873..29b8589cb8 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -89,13 +89,13 @@ 
         (sha256
          (base32
           "167hhv4wimkjnyfgqkyqmaiixhicbxacy6190gps98jyj4csi8ra"))
-        ;; Remove non-free or doubtful code, see
+        ;; Unbundle python2-pdf. 
         ;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
         (modules '((guix build utils)))
         (snippet
           '(begin
-            (delete-file "src/odf/thumbnail.py")
-            #t))
+             (delete-file-recursively "src/odf")
+             #t))
         (patches (search-patches "calibre-no-updates-dialog.patch"
                                  "calibre-remove-test-bs4.patch" ;; TODO: fix test.
                                  "calibre-remove-test-sqlite.patch" ;; TODO: fix test.
@@ -141,6 +141,7 @@ 
        ;; python2-msgpack is needed for the network content server to work.
        ("python2-msgpack" ,python2-msgpack)
        ("python2-netifaces" ,python2-netifaces)
+       ("python2-odfpy" ,python2-odfpy)
        ("python2-pillow" ,python2-pillow)
        ("python2-psutil" ,python2-psutil)
        ("python2-pygments" ,python2-pygments)