diff mbox series

[bug#35446,22/26] gnu: calibre: Disable bs4 test.

Message ID 20190427093659.21851-22-mail@brendan.scot
State Accepted
Headers show
Series [bug#35446,01/26] gnu: Use 'license:' prefix in (gnu packages web). | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch fail Apply failed

Commit Message

Brendan Tildesley April 27, 2019, 9:36 a.m. UTC
* gnu/local.mk: Reference patch
  gnu/packages/ebook.scm (calibre)[origin]: Enable patch.
  gnu/packages/patches/calibre-remove-test-sqlite.patch: New file.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/ebook.scm                        |  1 +
 .../patches/calibre-remove-test-sqlite.patch  | 29 +++++++++++++++++++
 3 files changed, 31 insertions(+)
 create mode 100644 gnu/packages/patches/calibre-remove-test-sqlite.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 47a45ad7ae..56f0738ffa 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -689,6 +689,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/byobu-writable-status.patch		\
   %D%/packages/patches/calibre-no-updates-dialog.patch		\
   %D%/packages/patches/calibre-remove-test-bs4.patch		\
+  %D%/packages/patches/calibre-remove-test-sqlite.patch		\
   %D%/packages/patches/calibre-remove-test-unrar.patch		\
   %D%/packages/patches/casync-renameat2-declaration.patch	\
   %D%/packages/patches/catdoc-CVE-2017-11110.patch		\
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 036e255158..e99487c56f 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -98,6 +98,7 @@ 
             #t))
         (patches (search-patches "calibre-no-updates-dialog.patch"
                                  "calibre-remove-test-bs4.patch" ;; TODO: fix test.
+                                 "calibre-remove-test-sqlite.patch" ;; TODO: fix test.
                                  "calibre-remove-test-unrar.patch"))))
     (build-system python-build-system)
     (native-inputs
diff --git a/gnu/packages/patches/calibre-remove-test-sqlite.patch b/gnu/packages/patches/calibre-remove-test-sqlite.patch
new file mode 100644
index 0000000000..7bdd90874d
--- /dev/null
+++ b/gnu/packages/patches/calibre-remove-test-sqlite.patch
@@ -0,0 +1,29 @@ 
+From a92e26359bd07743ab105819ed0b619e27e14017 Mon Sep 17 00:00:00 2001
+From: Brendan Tildesley <mail@brendan.scot>
+Date: Sat, 27 Apr 2019 03:30:53 +1000
+Subject: [PATCH] Disable test_sqlite.
+
+---
+ src/calibre/test_build.py | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/src/calibre/test_build.py b/src/calibre/test_build.py
+index 07bdffd3e5..740588c95b 100644
+--- a/src/calibre/test_build.py
++++ b/src/calibre/test_build.py
+@@ -162,12 +162,6 @@ class BuildTest(unittest.TestCase):
+             au(x, 'strftime')
+             self.assertEqual(unicode_type(time.strftime(fmt.replace('%e', '%#d'), t)), x)
+ 
+-    def test_sqlite(self):
+-        import sqlite3
+-        conn = sqlite3.connect(':memory:')
+-        from calibre.library.sqlite import load_c_extensions
+-        self.assertTrue(load_c_extensions(conn, True), 'Failed to load sqlite extension')
+-
+     def test_apsw(self):
+         import apsw
+         conn = apsw.Connection(':memory:')
+-- 
+2.21.0
+