[bug#34650,6/7] gnu: Add ruby-skinny.

Message ID 20190228174435.14499-6-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#34650,1/7] gnu: ruby-rack-protection: Update to 2.0.5. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Pierre Neidhardt Feb. 28, 2019, 5:44 p.m. UTC
* gnu/packages/ruby.scm (ruby-skinny): New variable.
---
 gnu/packages/ruby.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Christopher Baines March 4, 2019, 9:43 p.m. UTC | #1
Pierre Neidhardt <mail@ambrevar.xyz> writes:

> * gnu/packages/ruby.scm (ruby-skinny): New variable.
> ---
>  gnu/packages/ruby.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
> index 9d3c4b246..8cb170e17 100644
> --- a/gnu/packages/ruby.scm
> +++ b/gnu/packages/ruby.scm
> @@ -7783,3 +7783,34 @@ minimal effort.")
>  @end itemize\n")
>      (home-page "http://code.macournoyer.com/thin/")
>      (license license:ruby)))
> +
> +(define-public ruby-skinny
> +  (package
> +    (name "ruby-skinny")
> +    (version "0.2.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (rubygems-uri "skinny" version))
> +       (sha256
> +        (base32
> +         "1y3yvx88ylgz4d2s1wskjk5rkmrcr15q3ibzp1q88qwzr5y493a9"))))
> +    (build-system ruby-build-system)
> +    (arguments
> +     ;; TODO: Grab from GitHub to get tests?
> +     `(#:tests? #f

If there are no tests, I'd just put:

  '(#:tests? #f ; No included tests

> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-before 'build 'patch-gemspec
> +           (lambda _
> +             (substitute* ".gemspec"
> +               (("<eventmachine>.freeze, \\[\\\"~> 1.0.0\"")
> +                "<eventmachine>, [\">= 1.0.0\"")
> +               (("<thin>.freeze, \\[\\\"< 1.7\", ") "<thin>, [")))))))

Adding a explicit #t at the end of this phase.

> +    (propagated-inputs
> +     `(("ruby-eventmachine" ,ruby-eventmachine)
> +       ("ruby-thin" ,ruby-thin)))
> +    (synopsis "Simple, upgradable WebSockets for Ruby Thin")
> +    (description "Simple, upgradable WebSockets for Ruby Thin.")

The synopsis and description are the same. Even if there is no more
information to add, it would be good to at least provide a slightly
different description.

> +    (home-page "https://github.com/sj26/skinny")
> +    (license license:expat)))

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9d3c4b246..8cb170e17 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7783,3 +7783,34 @@  minimal effort.")
 @end itemize\n")
     (home-page "http://code.macournoyer.com/thin/")
     (license license:ruby)))
+
+(define-public ruby-skinny
+  (package
+    (name "ruby-skinny")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "skinny" version))
+       (sha256
+        (base32
+         "1y3yvx88ylgz4d2s1wskjk5rkmrcr15q3ibzp1q88qwzr5y493a9"))))
+    (build-system ruby-build-system)
+    (arguments
+     ;; TODO: Grab from GitHub to get tests?
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'patch-gemspec
+           (lambda _
+             (substitute* ".gemspec"
+               (("<eventmachine>.freeze, \\[\\\"~> 1.0.0\"")
+                "<eventmachine>, [\">= 1.0.0\"")
+               (("<thin>.freeze, \\[\\\"< 1.7\", ") "<thin>, [")))))))
+    (propagated-inputs
+     `(("ruby-eventmachine" ,ruby-eventmachine)
+       ("ruby-thin" ,ruby-thin)))
+    (synopsis "Simple, upgradable WebSockets for Ruby Thin")
+    (description "Simple, upgradable WebSockets for Ruby Thin.")
+    (home-page "https://github.com/sj26/skinny")
+    (license license:expat)))