[bug#34650,2/7] gnu: Add ruby-tilt.

Message ID 20190228174435.14499-2-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#34650,1/7] gnu: ruby-rack-protection: Update to 2.0.5. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Pierre Neidhardt Feb. 28, 2019, 5:44 p.m. UTC
* gnu/packages/ruby.scm (ruby-tilt): New variable.
---
 gnu/packages/ruby.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 63cfa8cf4..f6b6a19d5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7684,3 +7684,27 @@  uniquely identify it.")
 serves JavaScript, CoffeeScript, CSS, LESS, Sass, and SCSS.")
     (home-page "https://github.com/rails/sprockets")
     (license license:expat)))
+
+(define-public ruby-tilt
+  (package
+    (name "ruby-tilt")
+    (version "2.0.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "tilt" version))
+       (sha256
+        (base32
+         "0ca4k0clwf0rkvy7726x4nxpjxkpv67w043i39saxgldxd97zmwz"))))
+    (build-system ruby-build-system)
+    (arguments
+     ;; TODO: Fix tests.
+     `(#:tests? #f))
+    (synopsis "Generic interface to multiple Ruby template engines")
+    (description "Tilt is a thin interface over a bunch of different Ruby
+template engines in an attempt to make their usage as generic as
+possible.  This is useful for web frameworks, static site generators, and other
+systems that support multiple template engines but don't want to code for each
+of them individually.")
+    (home-page "https://github.com/rtomayko/tilt/")
+    (license license:expat)))