[bug#34650,3/7] gnu: Add ruby-mustermann.

Message ID 20190228174435.14499-3-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#34650,1/7] gnu: ruby-rack-protection: Update to 2.0.5. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Pierre Neidhardt Feb. 28, 2019, 5:44 p.m. UTC
* gnu/packages/ruby.scm (ruby-mustermann): New variable.
---
 gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Christopher Baines March 4, 2019, 9:20 p.m. UTC | #1
Pierre Neidhardt <mail@ambrevar.xyz> writes:

> * gnu/packages/ruby.scm (ruby-mustermann): New variable.
> ---
>  gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
> index f6b6a19d5..1c10a16c2 100644
> --- a/gnu/packages/ruby.scm
> +++ b/gnu/packages/ruby.scm
> @@ -7708,3 +7708,25 @@ systems that support multiple template engines but don't want to code for each
>  of them individually.")
>      (home-page "https://github.com/rtomayko/tilt/")
>      (license license:expat)))
> +
> +(define-public ruby-mustermann
> +  (package
> +    (name "ruby-mustermann")
> +    (version "1.0.3")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (rubygems-uri "mustermann" version))
> +       (sha256
> +        (base32
> +         "0lycgkmnyy0bf29nnd2zql5a6pcf8sp69g9v4xw0gcfcxgpwp7i1"))))
> +    (build-system ruby-build-system)
> +    (arguments
> +     ;; TODO: Fix tests.
> +     `(#:tests? #f))

Could you include some details of what is broken about the tests? Even
just a bit of the error message if there is one.

Also, I'd usually use a single quote unless a backtick is necessary.

> +    (synopsis "Library implementing patterns that behave like regular expressions")
> +    (description "Given a string pattern, Mustermann will turn it into an
> +object that behaves like a regular expression and has comparable performance
> +characteristics.")
> +    (home-page "https://github.com/sinatra/mustermann")
> +    (license license:expat)))

I'd recommend trying to avoid inserting packages at the end of modules,
or generally in the same place. This can make rebases difficult, and
increase the chances of conflicts when going to apply patches. I
generally try to fit patches in to modules somewhat alphabetically.

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f6b6a19d5..1c10a16c2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7708,3 +7708,25 @@  systems that support multiple template engines but don't want to code for each
 of them individually.")
     (home-page "https://github.com/rtomayko/tilt/")
     (license license:expat)))
+
+(define-public ruby-mustermann
+  (package
+    (name "ruby-mustermann")
+    (version "1.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "mustermann" version))
+       (sha256
+        (base32
+         "0lycgkmnyy0bf29nnd2zql5a6pcf8sp69g9v4xw0gcfcxgpwp7i1"))))
+    (build-system ruby-build-system)
+    (arguments
+     ;; TODO: Fix tests.
+     `(#:tests? #f))
+    (synopsis "Library implementing patterns that behave like regular expressions")
+    (description "Given a string pattern, Mustermann will turn it into an
+object that behaves like a regular expression and has comparable performance
+characteristics.")
+    (home-page "https://github.com/sinatra/mustermann")
+    (license license:expat)))