[bug#33290,7/8] gnu: demlo: Add workaround for go-1.11.

Message ID 20181106173709.9883-6-mail@ambrevar.xyz
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Pierre Neidhardt Nov. 6, 2018, 5:37 p.m. UTC
* gnu/packages/music.scm (demlo): Add workaround for go-1.11.
---
 gnu/packages/music.scm | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cdd06647e..bbdf58b18 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4235,7 +4235,10 @@  console music players.")
          ("go-github-com-michiwend-gomusicbrainz" ,go-github-com-michiwend-gomusicbrainz)
          ("go-github-com-stevedonovan-luar" ,go-github-com-stevedonovan-luar)
          ("go-github-com-wtolson-go-taglib" ,go-github-com-wtolson-go-taglib)
-         ("go-github-com-yookoala-realpath" ,go-github-com-yookoala-realpath)))
+         ("go-github-com-yookoala-realpath" ,go-github-com-yookoala-realpath)
+         ;; Those should not be needed, see TODO below.
+         ("pkg-config" ,pkg-config)
+         ("taglib" ,taglib)))
       (inputs
        `(("chromaprint" ,chromaprint)
          ("ffmpeg" ,ffmpeg)))
@@ -4243,6 +4246,23 @@  console music players.")
        `(#:import-path "gitlab.com/ambrevar/demlo"
          #:phases
          (modify-phases %standard-phases
+           ;; TODO: With our go-1.11, the golua .pkg is not re-used and gets
+           ;; rebuilt (https://bugs.gnu.org/32919).  Thus we need to
+           ;; re-specify the special flags of golua, the pkg-config + taglib
+           ;; native-inputs, and the 'check phase below.
+           (replace 'build
+             (lambda* (#:key import-path #:allow-other-keys)
+               (invoke "go" "install"
+                       "-v"  ; print the name of packages as they are compiled
+                       "-x"  ; print each command as it is invoked
+                       "-ldflags=-s -w" ; strip the symbol table and debug
+                       "-tags" "llua" ; Latest Lua on Guix does not have a version number.
+                       import-path)))
+           (replace 'check
+             (lambda* (#:key import-path #:allow-other-keys)
+               (invoke "go" "test"
+                       "-tags" "llua" ; Latest Lua on Guix does not have a version number.
+                       import-path)))
            (add-after 'install 'wrap-program
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let ((out (assoc-ref outputs "out"))