[bug#33290,6/8] gnu: go-github-com-stevedonovan-luar: Add workaround for go-1.11.

Message ID 20181106173709.9883-5-mail@ambrevar.xyz
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Pierre Neidhardt Nov. 6, 2018, 5:37 p.m. UTC
* gnu/packages/golang.scm (go-github-com-stevedonovan-luar): Add workaround for go-1.11.
---
 gnu/packages/golang.scm | 18 ++++++++++++++++--
 1 file changed, 16 insertions(+), 2 deletions(-)

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b6b726019..643ecda9f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2303,10 +2303,24 @@  similar word.")
            "1acjgw9cz1l0l9mzkyk7irz6cfk31wnxgbwa805fvm1rqcjzin2c"))))
       (build-system go-build-system)
       (native-inputs
-       `(("go-github-com-aarzilli-golua" ,go-github-com-aarzilli-golua)))
+       `(("go-github-com-aarzilli-golua" ,go-github-com-aarzilli-golua)
+         ("lua" ,lua)))
       (arguments
        `(#:tests? #f                    ; Upstream tests are broken.
-         #:import-path "github.com/stevedonovan/luar"))
+         #:import-path "github.com/stevedonovan/luar"
+         ;; TODO: With our go-1.11, the golua .pkg is not re-used and gets
+         ;; rebuilt (https://bugs.gnu.org/32919).  Thus we need to re-specify
+         ;; the special flags of golua and the "lua" native-input.
+         #:phases
+         (modify-phases %standard-phases
+           (replace 'build
+             (lambda* (#:key import-path #:allow-other-keys)
+               (invoke "go" "install"
+                       "-v"  ; print the name of packages as they are compiled
+                       "-x"  ; print each command as it is invoked
+                       "-ldflags=-s -w" ; strip the symbol table and debug
+                       "-tags" "llua" ; Latest Lua on Guix does not have a version number.
+                       import-path))))))
       (home-page "https://github.com/stevedonovan/luar")
       (synopsis "Lua reflection bindings for Go")
       (description "Luar is designed to make using Lua from Go more