[bug#33290,5/8] gnu: go-gitlab-com-ambrevar-golua-unicode: Add workaround for go-1.11.

Message ID 20181106173709.9883-4-mail@ambrevar.xyz
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Pierre Neidhardt Nov. 6, 2018, 5:37 p.m. UTC
* gnu/packages/golang.scm (go-gitlab-com-ambrevar-golua-unicode): Add workaround for go-1.11.
---
 gnu/packages/golang.scm | 15 ++++++++++++++-
 1 file changed, 14 insertions(+), 1 deletion(-)

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a4978af2a..b6b726019 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2204,10 +2204,23 @@  run a Lua virtual machine.")
          #:import-path "gitlab.com/ambrevar/golua/unicode"
          #:phases
          (modify-phases %standard-phases
+           ;; TODO: With our go-1.11, the golua .pkg is not re-used and gets
+           ;; rebuilt (https://bugs.gnu.org/32919).  Thus we need to re-specify
+           ;; the special flags of golua here and in the 'check phase below.
+           (replace 'build
+             (lambda* (#:key import-path #:allow-other-keys)
+               (invoke "go" "install"
+                       "-v"  ; print the name of packages as they are compiled
+                       "-x"  ; print each command as it is invoked
+                       "-ldflags=-s -w" ; strip the symbol table and debug
+                       "-tags" "llua" ; Latest Lua on Guix does not have a version number.
+                       import-path)))
            (replace 'check
              (lambda* (#:key import-path #:allow-other-keys)
                (setenv "USER" "homeless-dude")
-               (invoke "go" "test" import-path))))))
+               (invoke "go" "test"
+                       "-tags" "llua" ; Latest Lua on Guix does not have a version number.
+                       import-path))))))
       (home-page "https://gitlab.com/ambrevar/golua")
       (synopsis "Add Unicode support to Golua")
       (description "This extension to Arzilli's Golua adds Unicode support to