[bug#33136,5/7] gnu: qt@4: Update license list.

Message ID 20181024114134.3116-5-efraim@flashner.co.il
State Accepted
Headers show
Series Qt updates | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Efraim Flashner Oct. 24, 2018, 11:41 a.m. UTC
* gnu/packages/qt.scm (qt@4)[license]: Fix license information.
---
 gnu/packages/qt.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Danny Milosavljevic Oct. 26, 2018, 9:49 a.m. UTC | #1
> +              #t))))))
> +      (license (list license:lgpl2.1 license:gpl3))))

Maybe add a comment with details (is it a choice (either/or), which files roughly under which license etc).
Efraim Flashner Oct. 28, 2018, 8:13 a.m. UTC | #2
On Fri, Oct 26, 2018 at 11:49:08AM +0200, Danny Milosavljevic wrote:
> > +              #t))))))
> > +      (license (list license:lgpl2.1 license:gpl3))))
> 
> Maybe add a comment with details (is it a choice (either/or), which files roughly under which license etc).

I just tried building qt@4 again and this time I didn't get the license
list output at the end of the configure phase, so I'm going to leave
this out for now.

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 65ba4af88..6d9b3f95e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -487,7 +487,8 @@  system, and the core design of Django is reused in Grantlee.")
               ;; different "devices" due to bind-mounts.
               (copy-recursively olddoc docdir)
               (delete-file-recursively olddoc)
-              #t))))))))
+              #t))))))
+      (license (list license:lgpl2.1 license:gpl3))))
 
 (define-public qtbase
   (package