[bug#33136,6/7] gnu: qt@4: Update build config.

Message ID 20181024114134.3116-6-efraim@flashner.co.il
State Accepted
Commit 1f71daf499c1c0708f56cd4623d07082a355fff3
Headers show
Series Qt updates | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Efraim Flashner Oct. 24, 2018, 11:41 a.m. UTC
* gnu/packages/qt.scm (qt@4)[arguments]: Substitute hardcoded '/bin/ls'
invocation. Add configure-flags to not build the examples or demos.
Don't use the precompiled headers.
---
 gnu/packages/qt.scm | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Danny Milosavljevic Oct. 26, 2018, 9:50 a.m. UTC | #1
LGTM!

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 6d9b3f95e..966b35456 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -430,11 +430,14 @@  system, and the core design of Django is reused in Grantlee.")
                   (doc (assoc-ref outputs "doc")))
               (substitute* '("configure")
                 (("/bin/pwd") (which "pwd")))
+              (substitute* "src/corelib/global/global.pri"
+                (("/bin/ls") (which "ls")))
 
               (zero? (system*
                       "./configure"
                       "-verbose"
                       "-prefix" out
+                      "-nomake" "examples demos"
                       ;; Note: Don't pass '-docdir' since 'qmake' and
                       ;; libQtCore would record its value, thereby defeating
                       ;; the whole point of having a separate output.
@@ -457,6 +460,8 @@  system, and the core design of Django is reused in Grantlee.")
                       ;; Skip the webkit module; it fails to build on armhf
                       ;; and, apart from that, may pose security risks.
                       "-no-webkit"
+                      ;; don't use the precompiled headers
+                      "-no-pch"
                       ;; drop special machine instructions not supported
                       ;; on all instances of the target
                       ,@(if (string-prefix? "x86_64"