[bug#33136,3/7] gnu: qt: Add vulkan support.

Message ID 20181024114134.3116-3-efraim@flashner.co.il
State Accepted
Headers show
Series Qt updates | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Efraim Flashner Oct. 24, 2018, 11:41 a.m. UTC
* gnu/packages/qt.scm (qt, qtbase)[native-inputs]: Add vulkan-headers.
(qt@4)[native-inputs]: Don't add vulkan-headers.
(qttools)[native-inputs]: Add vulkan-headers.
---
 gnu/packages/qt.scm | 23 +++++++++++++++++------
 1 file changed, 17 insertions(+), 6 deletions(-)

Comments

Danny Milosavljevic Oct. 26, 2018, 9:47 a.m. UTC | #1
Hi,

On Wed, 24 Oct 2018 14:41:30 +0300
Efraim Flashner <efraim@flashner.co.il> wrote:

> +               '("harfbuzz" "libjepg"))
> +       ("libjepg" ,libjpeg-8)

Any reason we are calling this "libjepg" [sic] ?

Otherwise LGTM!
Efraim Flashner Oct. 27, 2018, 8:21 p.m. UTC | #2
On Fri, Oct 26, 2018 at 11:47:54AM +0200, Danny Milosavljevic wrote:
> Hi,
> 
> On Wed, 24 Oct 2018 14:41:30 +0300
> Efraim Flashner <efraim@flashner.co.il> wrote:
> 
> > +               '("harfbuzz" "libjepg"))
> > +       ("libjepg" ,libjpeg-8)
> 
> Any reason we are calling this "libjepg" [sic] ?
> 
> Otherwise LGTM!

Looks like I'm maintining the typo :)

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index dffa8b5cf..143ca45b7 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -64,9 +64,11 @@ 
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages vulkan)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
-  #:use-module (gnu packages xml))
+  #:use-module (gnu packages xml)
+  #:use-module (srfi srfi-1))
 
 (define-public grantlee
   (package
@@ -224,6 +226,7 @@  system, and the core design of Django is reused in Grantlee.")
        ("pkg-config" ,pkg-config)
        ("python" ,python-2)
        ("ruby" ,ruby)
+       ("vulkan-headers" ,vulkan-headers)
        ("which" ,(@ (gnu packages base) which))))
     (arguments
      `(#:parallel-build? #f ; Triggers race condition in qtbase module on Hydra.
@@ -401,10 +404,16 @@  system, and the core design of Django is reused in Grantlee.")
               ;; Remove webkit module, which is not built.
               '(begin (delete-file-recursively "src/3rdparty/webkit")
                       #t))))
-    (inputs `(,@(alist-delete "harfbuzz"
-                              (alist-delete "libjpeg" (package-inputs qt)))
-              ("libjepg" ,libjpeg-8)
-              ("libsm" ,libsm)))
+    (inputs
+     `(,@(fold alist-delete
+               (package-inputs qt)
+               '("harfbuzz" "libjepg"))
+       ("libjepg" ,libjpeg-8)
+       ("libsm" ,libsm)))
+    (native-inputs
+     `(,@(fold alist-delete
+               (package-native-inputs qt)
+               '("vulkan-headers"))))
 
     ;; Note: there are 37 MiB of examples and a '-exampledir' configure flags,
     ;; but we can't make them a separate output because "out" and "examples"
@@ -560,6 +569,7 @@  system, and the core design of Django is reused in Grantlee.")
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python" ,python-2)
+       ("vulkan-headers" ,vulkan-headers)
        ("ruby" ,ruby)))
     (arguments
      `(#:phases
@@ -1283,7 +1293,8 @@  positioning and geolocation plugins.")))
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
     (native-inputs
      `(("perl" ,perl)
-       ("qtdeclarative" ,qtdeclarative)))
+       ("qtdeclarative" ,qtdeclarative)
+       ("vulkan-headers" ,vulkan-headers)))
     (inputs
      `(("mesa" ,mesa)
        ("qtbase" ,qtbase)))