mbox series

[bug#71023,0/9] Update fzf to 0.52.1

Message ID cover.1715964816.git.luishenriquegh2701@gmail.com
Headers show
Series Update fzf to 0.52.1 | expand

Message

Luis Henrique Gomes Higino May 18, 2024, 12:32 a.m. UTC
Hi Guix,

this patch series updates fzf to version 0.52.1. In the process, I had to
update the go version of some depending libraries, which resulted in some
other packages failing to build. I tried to fix all related packages, but the
amount of changes came to a point where I think I'll have missed some
more. I'm hoping guix ci to help me with this, as I'm willing to fix them all
myself.

*** BLURB HERE ***

Luis Higino (9):
  gnu: Add go-github-com-charlievieth-fastwalk.
  gnu: aerc: Update go version.
  gnu: vale: Update go version.
  gnu: senpai: Update go version.
  gnu: chezmoi: Update go version.
  gnu: games.scm: Update go versions.
  gnu: golang-xyz.scm: Update go versions.
  gnu: golang.scm: Update packages and go versions.
  gnu: go-github-com-junegunn-fzf: Update to 0.52.1.

 gnu/packages/configuration-management.scm | 67 +++++++++----------
 gnu/packages/games.scm                    |  8 ++-
 gnu/packages/golang-xyz.scm               |  6 +-
 gnu/packages/golang.scm                   | 78 +++++++++++++++++------
 gnu/packages/mail.scm                     |  3 +-
 gnu/packages/messaging.scm                |  1 +
 gnu/packages/terminals.scm                | 15 +++--
 gnu/packages/textutils.scm                |  1 +
 8 files changed, 120 insertions(+), 59 deletions(-)


base-commit: e4ee595999a3b0656f416d190b28ec6f1ad8a74d

Comments

Sharlatan Hellseher May 21, 2024, 8:49 p.m. UTC | #1
Hi,

Thank you for the patches.

From the first glance, some of the changes need to be grouped as single commit
- [PATCH 8/9] gnu: golang.scm: Update packages and go versions.

A general cement to all of them - is everything related just to bump fzf
to the latest version or it's a collection of not related patches?

I'm on the way to update valve to the latest version which is quite a
massive change in dependencies tree.

Also try to avoid adding any new packages to golang.scm.

--
Oleg
Luis Henrique Gomes Higino June 4, 2024, 5 p.m. UTC | #2
Hi Oleg,

> From the first glance, some of the changes need to be grouped as 
> single commit - [PATCH 8/9] gnu: golang.scm: Update packages and 
> go versions.

thanks for the feedback! I didn't know it was OK to group commits, 
do you think all commits before the last one should be grouped?

> A general cement to all of them - is everything related just to 
> bump fzf to the latest version or it's a collection of not 
> related patches?

So, to upgrade fzf I had to update some of its dependencies and, 
due to it, had to update their go versions from 17 to 18. When I 
checked if any other dependent packages were affected with =guix 
refresh=, it showed to me that the packages were not building 
because they were compiled with Go 17 and it seems the 
=go-build-system= vendorizes all package dependencies before 
building. I tried fixing only the packages that were broken, so I 
guess they are all related in that sense. I'm totally open to 
being convinced otherwise though :)

> Also try to avoid adding any new packages to golang.scm.

OK, I read some other packages there and it seemed to me that 
=fastwalk= was similar in nature to the ones near it (where I 
inserted it). Should I move it to =golang-xyz.scm= instead?
Andreas Enge June 10, 2024, 10:14 a.m. UTC | #3
Hello,

I think there has been some misunderstanding, it is the other way round:
Every package change needs its own commit, even if they are in the same
file. So commit 8/9 should be split into several ones.

When doing so, you may wish to use the ./etc/committer.scm script in the
source tree: Update a package and run the script, which often creates a
good commit.

Updating many packages at the same time can become a bit unwieldy; it
might be easier to update in smaller chunks, starting with only some
dependencies (if this is possible depends of course on how entangled
the situation is).

Andreas