diff mbox series

[bug#71023,5/9] gnu: chezmoi: Update go version.

Message ID 4b90f13cc76d9ce76948e9c5de30ec8ea1b19474.1715964816.git.luishenriquegh2701@gmail.com
State New
Headers show
Series Update fzf to 0.52.1 | expand

Commit Message

Luis Henrique Gomes Higino May 18, 2024, 1:11 a.m. UTC
* gnu/packages/configuration-management.scm (chezmoi): Update go version.

Change-Id: Iac2d344a4b48fc9296528bee84a59598ff45c61b
---
 gnu/packages/configuration-management.scm | 67 ++++++++++++-----------
 1 file changed, 35 insertions(+), 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index de27f50e0c..d67db49e7a 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -18,6 +18,7 @@ 
 
 (define-module (gnu packages configuration-management)
   #:use-module (gnu packages)
+  #:use-module (guix gexp)
   #:use-module (guix build-system go)
   #:use-module (guix git-download)
   #:use-module (gnu packages golang)
@@ -45,38 +46,40 @@  (define-public chezmoi
                 "0ildvlq7v8vnw74y4fgnv3hpq49bpl6zh1wmakfh46crwg7ffmjb"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/twpayne/chezmoi"
-       #:install-source? #f
-       #:phases
-       (modify-phases %standard-phases
-       ;; Remove test script which expect additional user's programs available
-       ;; in the PATH. The testdata directory is removed in the latest version
-       ;; (2.46.1) of the program.
-         (add-after 'unpack 'remove-failing-test-scripts
-           (lambda* (#:key import-path #:allow-other-keys)
-             (for-each (lambda (f)
-                         (delete-file (string-append "src/" import-path "/testdata/scripts/" f)))
-                       '("bitwarden.txt"
-                         "cd.txt"
-                         "cd_unix.txt"
-                         "completion.txt"
-                         "diff.txt"
-                         "edit.txt"
-                         "editconfig.txt"
-                         "git.txt"
-                         "gopass.txt"
-                         "keepassxc.txt"
-                         "lastpass.txt"
-                         "onepassword.txt"
-                         "pass.txt"
-                         "runscriptdir_unix.txt"
-                         "script_unix.txt"
-                         "secretgeneric.txt"
-                         "secretgopass.txt"
-                         "secretkeepassxc.txt"
-                         "secretlastpass.txt"
-                         "secretonepassword.txt"
-                         "secretpass.txt")))))))
+     (list
+      #:go go-1.18
+      #:import-path "github.com/twpayne/chezmoi"
+      #:install-source? #f
+      #:phases
+      #~(modify-phases %standard-phases
+        ;; Remove test script which expect additional user's programs available
+        ;; in the PATH. The testdata directory is removed in the latest version
+        ;; (2.46.1) of the program.
+        (add-after 'unpack 'remove-failing-test-scripts
+          (lambda* (#:key import-path #:allow-other-keys)
+            (for-each (lambda (f)
+                        (delete-file (string-append "src/" import-path "/testdata/scripts/" f)))
+                      '("bitwarden.txt"
+                        "cd.txt"
+                        "cd_unix.txt"
+                        "completion.txt"
+                        "diff.txt"
+                        "edit.txt"
+                        "editconfig.txt"
+                        "git.txt"
+                        "gopass.txt"
+                        "keepassxc.txt"
+                        "lastpass.txt"
+                        "onepassword.txt"
+                        "pass.txt"
+                        "runscriptdir_unix.txt"
+                        "script_unix.txt"
+                        "secretgeneric.txt"
+                        "secretgopass.txt"
+                        "secretkeepassxc.txt"
+                        "secretlastpass.txt"
+                        "secretonepassword.txt"
+                        "secretpass.txt")))))))
     (native-inputs
      (list go-etcd-io-bbolt
            go-github-com-alecthomas-chroma