mbox series

[bug#52610,00/42] Revising sequoia packaging and update to 1.6

Message ID cover.1639859819.git.h.goebel@crazy-compilers.com
Headers show
Series Revising sequoia packaging and update to 1.6 | expand

Message

Hartmut Goebel Dec. 18, 2021, 8:49 p.m. UTC
This implements the following changes I announced some weeks ago, see
<https://lists.gnu.org/archive/html/guix-devel/2021-11/msg00221.html>.
It also updates each sequoia package to its current version.

* Move all sequoia related crates in to sequoia.scm. As of now these are only
  rust-sequoia-openpgp-0.9, rust-sequoia-rfc2822-0.9 and there is only on
  package depending on them rust-libpijul-0.12

* bufferedreader, rust-nettle and other crates from the sequoia project but
  not having "sequoia" (or such) in the name would be kept in crates-io.scm

* In sequoia.scm there would be all sequoia crates, with the app packages
  named without "rust-" prefix ("sequoia-sq", …)

* The current "sequoia" package will become a "wrapper", just propagating (or
  copying, what ever is more common in guix) the other packages which have an
  actual output.

Hartmut Goebel (42):
  gnu: rust-nettle: Update to 7.0.2.
  gnu: rust-criterion-0.3: Update to 0.3.4.
  gnu: rust-serde-1: Update to 1.0.126.
  gnu: rust-serde-derive-1: Update to 1.0.126.
  gnu: rust-wasm-bindgen-futures-0.4: Update to 0.4.24.
  gnu: rust-wasm-bindgen-test-0.3: Update to 0.3.24.
  gnu: rust-wasm-bindgen-test-macro-0.3: Update to 0.3.24.
  gnu: rust-wasm-bindgen-0.2: Update to 0.2.74.
  gnu: rust-wasm-bindgen-backend-0.2: Update to 0.2.74.
  gnu: rust-wasm-bindgen-macro-0.2: Update to 0.2.74.
  gnu: rust-wasm-bindgen-macro-support-0.2: Update to 0.2.74.
  gnu: rust-wasm-bindgen-shared-0.2: Update to 0.2.74.
  gnu: rust-js-sys-0.3: Update to 0.3.51.
  gnu: rust-web-sys-0.3: Update to 0.3.51.
  gnu: rust-version-compare 0.0.11: Fix variable name.
  gnu: Add rust-ttf-parser-0.12.
  gnu: Add rust-gif-0.11.
  gnu: Add rust-fallible-collections-0.3.
  gnu: Add rust-target-lexicon-0.11.
  gnu: Add rust-dcv-color-primitives-0.1.
  gnu: Add rust-cfg-expr-0.7.
  gnu: Add rust-system-deps-3.
  gnu: Add rust-pathfinder-simd-0.5.
  gnu: Add rust-pathfinder-geometry-0.5.
  gnu: Add rust-freetype-0.7.
  gnu: Add rust-font-kit-0.10.
  gnu: Add rust-plotters-backend-0.3.
  gnu: Add rust-plotters-bitmap-0.3.
  gnu: Add rust-plotters-svg-0.3.
  gnu: Add rust-plotters-0.3.
  gnu: Add rust-buffered-reader-1.
  gnu: Add rust-xxhash-rust-0.8.
  gnu: Add rust-sequoia-openpgp-1.
  gnu: Add rust-sequoia-net-0.23.
  gnu: Add rust-sequoia-ipc-0.25.
  gnu: Add rust-sequoia-autocrypt-0.23.
  gnu: Add sequoia-sq.
  gnu: Add sequoia-sqv.
  gnu: Add libsequoia.
  gnu: sequoia: Change into a meta-package and update to 1.6.0.
  gnu: rust-sequoia-openpgp-0.9: Move to (gnu packages sequoia).
  gnu: rust-sequoia-rfc2822-0.9: Move to (gnu packages sequoia).

 gnu/local.mk                                  |   2 +
 gnu/packages/crates-io.scm                    | 652 ++++++++++++------
 .../patches/libsequoia-fix-ffi-Makefile.patch |  32 +
 .../patches/libsequoia-remove-store.patch     | 432 ++++++++++++
 gnu/packages/sequoia.scm                      | 600 ++++++++++++----
 5 files changed, 1399 insertions(+), 319 deletions(-)
 create mode 100644 gnu/packages/patches/libsequoia-fix-ffi-Makefile.patch
 create mode 100644 gnu/packages/patches/libsequoia-remove-store.patch

Comments

Nicolas Goaziou Dec. 30, 2021, 12:27 a.m. UTC | #1
Hello

Hartmut Goebel <h.goebel@crazy-compilers.com> writes:

> This implements the following changes I announced some weeks ago, see
> <https://lists.gnu.org/archive/html/guix-devel/2021-11/msg00221.html>.
> It also updates each sequoia package to its current version.
>
> * Move all sequoia related crates in to sequoia.scm. As of now these are only
>   rust-sequoia-openpgp-0.9, rust-sequoia-rfc2822-0.9 and there is only on
>   package depending on them rust-libpijul-0.12
>
> * bufferedreader, rust-nettle and other crates from the sequoia project but
>   not having "sequoia" (or such) in the name would be kept in crates-io.scm
>
> * In sequoia.scm there would be all sequoia crates, with the app packages
>   named without "rust-" prefix ("sequoia-sq", …)
>
> * The current "sequoia" package will become a "wrapper", just propagating (or
>   copying, what ever is more common in guix) the other packages which have an
>   actual output.

Nice.

Note that some patches are not necessary anymore (e.g., updating
rust-criterion-0.3).

Also, please remove trailing #t in packages definitions (snippets and
phases) and make sequoia use new package style (e.g., $#sequoia-sqv
instead of (assoc-ref %build-inputs "sequoia-sqv") and $#output instead
of (assoc-ref %outputs "out")).

Otherwise, LGTM.

Regards,
Hartmut Goebel Dec. 30, 2021, 8:41 p.m. UTC | #2
Updated and pushed as bf7ed7c9f2083e5bf81fffa41e2e7213817d5acd.
Thanks for the review

It took me quite some time to figure out how toe use the new gexp/ungexp 
since documentation and examples are rare. So now we have an example how 
to use gexp and cargo-inputs :-)