diff mbox series

[bug#52610,42/42] gnu: rust-sequoia-rfc2822-0.9: Move to (gnu packages sequoia).

Message ID 632c7b34d32c7ba4053528da8d379f8f21370bef.1639859823.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Revising sequoia packaging and update to 1.6 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Dec. 18, 2021, 8:49 p.m. UTC
* gnu/packages/crates-io.scm (rust-sequoia-rfc2822-0.9): Move package to ...
* gnu/packages/sequoia.scm: ... here. [arguments]<skip-build?> Add.
  <cargo-development-inputs>: Remove. [description] Reformat and add markup.
---
 gnu/packages/crates-io.scm | 39 --------------------------------------
 gnu/packages/sequoia.scm   | 28 +++++++++++++++++++++++++++
 2 files changed, 28 insertions(+), 39 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2fb35277a4..5d62156abe 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46923,45 +46923,6 @@  formats:
 fragment of code.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-sequoia-rfc2822-0.9
-  (package
-    (name "rust-sequoia-rfc2822")
-    (version "0.9.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "sequoia-rfc2822" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "1aj34i6862718m162rqfv69fkmvdw063s6ws7hbp42n73gb08p5c"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-failure" ,rust-failure-0.1)
-        ("rust-lalrpop" ,rust-lalrpop-0.17)
-        ("rust-lalrpop-util" ,rust-lalrpop-util-0.17))
-       #:cargo-development-inputs
-       (("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-quickcheck" ,rust-quickcheck-0.8)
-        ("rust-rand" ,rust-rand-0.6))))
-    (home-page "https://sequoia-pgp.org/")
-    (synopsis "RFC 2822 name-addr parser")
-    (description
-     "Currently, this crate only recognizes the RFC 2822 name-addr and
-addr-spec productions, i.e., things of the form:
-
-Name (Comment) <email@@example.org>
-
-and
-
-email@@example.org
-
-Although the above appear simple to parse, RFC 2822's whitespace and comment
-rules are rather complex.  This crate implements the whole grammar." )
-    (license license:gpl3)))
-
 (define-public rust-serde-1
   (package
     (name "rust-serde")
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index 3db85a9eba..bbab42bff8 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -283,6 +283,34 @@  This Guix package is built to use the nettle cryptographic library.")
         ("rust-sequoia-rfc2822" ,rust-sequoia-rfc2822-0.9)
         ("rust-time" ,rust-time-0.1))))))
 
+(define-public rust-sequoia-rfc2822-0.9
+  (package
+    (name "rust-sequoia-rfc2822")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "sequoia-rfc2822" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1aj34i6862718m162rqfv69fkmvdw063s6ws7hbp42n73gb08p5c"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-failure" ,rust-failure-0.1)
+        ("rust-lalrpop" ,rust-lalrpop-0.17)
+        ("rust-lalrpop-util" ,rust-lalrpop-util-0.17))))
+    (home-page "https://sequoia-pgp.org/")
+    (synopsis "RFC 2822 name-addr parser")
+    (description "Currently, this crate only recognizes the RFC 2822 name-addr
+and addr-spec productions, i.e., things of the form: @code{Name (Comment)
+<email@@example.org>} and @code{email@@example.org}
+
+Although the above appear simple to parse, RFC 2822's whitespace and comment
+rules are rather complex.  This crate implements the whole grammar." )
+    (license license:gpl3)))
+
 (define-public sequoia-sq
   (package
     (name "sequoia-sq")