[bug#33980] gnu: Add pwsafe

Message ID 0b3c2a46-255a-968b-c0a8-1c2b750352d4@yahoo.de
State Accepted
Headers show
Series [bug#33980] gnu: Add pwsafe | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Tim Gesthuizen Jan. 4, 2019, 10:32 p.m. UTC
Hi,
The attached patch adds pwsafe.
Please tell me if something is wrong with the patch.

Tim.

Comments

Ludovic Courtès Jan. 9, 2019, 5 p.m. UTC | #1
Hi Tim,

Tim Gesthuizen <tim.gesthuizen@yahoo.de> skribis:

> From b85b078e18a8166231320f05e938f5f0264f5097 Mon Sep 17 00:00:00 2001
> From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
> Date: Sat, 29 Dec 2018 23:21:58 +0100
> Subject: [PATCH] gnu: Add pwsafe
>
> * gnu/packages/password-utils.scm (pwsafe): New variable

Overall LGTM.  Nitpicking:

> +    ;; TODO: The help subsystem cannot be initialized
> +    ;; TODO: pwsafe tries to download GTest which does not work in the daemon
> +    ;; environment and is not functional. Substitute CMakeLists.txt to use
> +    ;; native GTest and reenable unit tests.
> +    (arguments '(#:configure-flags (list "-DNO_GTEST=YES")))

It would be ideal if you could get the tests running.  :-)

> +    (native-inputs `(("coreutils" ,coreutils)

Coreutils is not needed, it’s an implicit input already.

> +    (synopsis "Password safe to store passwords encrypted")
> +    (description "A password manager originally designed by Bruce Schneier.
> +It offers a simple UI to manage passwords for different services.  There are
> +other programs that support the file format on different plattforms.")
                                                               ^^
Typo.

Also please make full sentences.

Could you send an updated patch?

Thank you,
Ludo’.

Patch

From b85b078e18a8166231320f05e938f5f0264f5097 Mon Sep 17 00:00:00 2001
From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
Date: Sat, 29 Dec 2018 23:21:58 +0100
Subject: [PATCH] gnu: Add pwsafe

* gnu/packages/password-utils.scm (pwsafe): New variable
---
 gnu/packages/password-utils.scm | 41 +++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 357ef86d5..31b303a1e 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
+;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -42,6 +43,7 @@ 
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
@@ -52,6 +54,7 @@ 
   #:use-module (gnu packages crypto)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gnuzilla)
@@ -72,6 +75,7 @@ 
   #:use-module (gnu packages tls)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages version-control)
+  #:use-module (gnu packages wxwidgets)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages xml)
@@ -168,6 +172,43 @@  algorithms AES or Twofish.")
     (license license:gpl3)
     (properties `((superseded . ,keepassxc)))))
 
+(define-public pwsafe
+  (package
+    (name "pwsafe")
+    (version "3.48.0")
+    (home-page "https://www.pwsafe.org/" )
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pwsafe/pwsafe.git")
+             (commit version)))
+       (sha256 (base32 "0hxv23yh76liggxbjn4m132z15sklra8ms341xgzl4n5vjx30ihi"))
+       (file-name (string-append name "-" version "-checkout"))))
+    (build-system cmake-build-system)
+    ;; TODO: The help subsystem cannot be initialized
+    ;; TODO: pwsafe tries to download GTest which does not work in the daemon
+    ;; environment and is not functional. Substitute CMakeLists.txt to use
+    ;; native GTest and reenable unit tests.
+    (arguments '(#:configure-flags (list "-DNO_GTEST=YES")))
+    (native-inputs `(("coreutils" ,coreutils)
+                     ("gettext" ,gettext-minimal)
+                     ("perl" ,perl)
+                     ("zip" ,zip)))
+    (inputs `(("curl" ,curl)
+              ("libuuid" ,util-linux)
+              ("libxt" ,libxt)
+              ("libxtst" ,libxtst)
+              ("openssl" ,openssl)
+              ("qrencode" ,qrencode)
+              ("wxwidgets" ,wxwidgets)
+              ("xerces-c" ,xerces-c)))
+    (synopsis "Password safe to store passwords encrypted")
+    (description "A password manager originally designed by Bruce Schneier.
+It offers a simple UI to manage passwords for different services.  There are
+other programs that support the file format on different plattforms.")
+    (license license:artistic2.0)))
+
 (define-public shroud
   (package
     (name "shroud")
-- 
2.20.1