mbox series

[bug#49889,0/5] Add build system for Gerbil Scheme

Message ID cover.1628172101.git.public@yoctocell.xyz
Headers show
Series Add build system for Gerbil Scheme | expand

Message

Xinglu Chen Aug. 5, 2021, 2:06 p.m. UTC
This series adds the ‘gerbil-build-system’ for building Gerbil packages.

The first patch moves the ‘gerbil’ package from (gnu packages scheme) to
(gnu packages gerbil).

The third patch adds the build system itself, and the fourth and fifth
patches add two Gerbil packages that use the new ‘gerbil-build-system’.

I don’t know if Gerbil packages should be ‘inputs’ or
‘propagated-inputs’.  I found two Gerbil packages that depended on other
Gerbil packages, but they both require a newer, unreleased Gerbil
package (Gerbil hasn’t had a new release for more than a year).  Maybe
we should add a ‘gerbil-next’ package?  ;-)

Xinglu Chen (5):
  gnu: gerbil: Move to (gnu packages gerbil).
  gnu: gerbil: Add 'native-search-paths' field.
  guix: Add 'gerbil-build-system'.
  gnu: Add gerbil-srfi-54.
  gnu: Add gerbil-clojerbil.

 Makefile.am                           |   2 +
 doc/guix.texi                         |  21 +++
 etc/snippets/scheme-mode/guix-package |   1 +
 gnu/local.mk                          |   2 +
 gnu/packages/gerbil.scm               | 199 ++++++++++++++++++++++++++
 gnu/packages/scheme.scm               | 105 +-------------
 guix/build-system/gerbil.scm          | 138 ++++++++++++++++++
 guix/build/gerbil-build-system.scm    |  78 ++++++++++
 8 files changed, 442 insertions(+), 104 deletions(-)
 create mode 100644 gnu/packages/gerbil.scm
 create mode 100644 guix/build-system/gerbil.scm
 create mode 100644 guix/build/gerbil-build-system.scm


base-commit: 517dacdb99e15f35c0ead462c9156896b5728be4

Comments

Ludovic Courtès Feb. 4, 2022, 9:42 p.m. UTC | #1
Hello!

Xinglu Chen <public@yoctocell.xyz> skribis:

> This series adds the ‘gerbil-build-system’ for building Gerbil packages.
>
> The first patch moves the ‘gerbil’ package from (gnu packages scheme) to
> (gnu packages gerbil).
>
> The third patch adds the build system itself, and the fourth and fifth
> patches add two Gerbil packages that use the new ‘gerbil-build-system’.
>
> I don’t know if Gerbil packages should be ‘inputs’ or
> ‘propagated-inputs’.  I found two Gerbil packages that depended on other
> Gerbil packages, but they both require a newer, unreleased Gerbil
> package (Gerbil hasn’t had a new release for more than a year).  Maybe
> we should add a ‘gerbil-next’ package?  ;-)
>
> Xinglu Chen (5):
>   gnu: gerbil: Move to (gnu packages gerbil).
>   gnu: gerbil: Add 'native-search-paths' field.
>   guix: Add 'gerbil-build-system'.
>   gnu: Add gerbil-srfi-54.
>   gnu: Add gerbil-clojerbil.

Looks like this fell through the cracks during the summer.  :-/

It all LGTM.  You’ll have to update the build system to the new API
though, and run ‘guix style -S inputs’ to remove input labels, and
possibly ‘guix style’ to adjust layout for ‘gerbil-clojerbil’ for
instance.

That’s all.

Could you send updated patches?

Thanks!

Ludo’.