[bug#34137] gnu: Add ghc-libmpd.

Message ID 87va2dc1dw.fsf@gmail.com
State Accepted
Commit 4ad7d037ad373a46e341354b19f0b17c737beebb
Headers show
Series [bug#34137] gnu: Add ghc-libmpd. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Gabriel Hondet Jan. 24, 2019, 7:16 p.m. UTC
Hi,

Here is a new patch following your remarks.  I have also used
'mirror://' for hackage.

* gnu/packages/haskell.scm (ghc-libmpd): New variable.
---
 gnu/packages/haskell.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Ludovic Courtès Jan. 25, 2019, 1:06 p.m. UTC | #1
Hello,

Gabriel Hondet <gabrielhondet@gmail.com> skribis:

> Here is a new patch following your remarks.  I have also used
> 'mirror://' for hackage.
>
> * gnu/packages/haskell.scm (ghc-libmpd): New variable.

Applied, thanks!

Ludo’.

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b8ea36852..255e902e6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11461,4 +11461,36 @@  foreign imports by hand (or using hsc2hs), this ensures that C functions are
 imported with the correct Haskell types.")
     (license license:gpl2)))
 
+(define-public ghc-libmpd
+  (package
+    (name "ghc-libmpd")
+    (version "0.9.0.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://hackage/package/libmpd/libmpd-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1931m23iqb4wddpdidm4ph746zpaw41kkjzmb074j7yyfpk7x1jv"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-attoparsec" ,ghc-attoparsec)
+       ("ghc-old-locale" ,ghc-old-locale)
+       ("ghc-text" ,ghc-text)
+       ("ghc-data-default-class" ,ghc-data-default-class)
+       ("ghc-network" ,ghc-network)
+       ("ghc-utf8-string" ,ghc-utf8-string)))
+    (native-inputs
+     `(("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-hspec" ,ghc-hspec)
+       ("hspec-discover" ,hspec-discover)))
+    (home-page "https://github.com/vimus/libmpd-haskell")
+    (synopsis "Haskell client library for the Music Player Daemon")
+    (description "This package provides a pure Haskell client library for the
+Music Player Daemon.")
+    (license license:expat)))
+
 ;;; haskell.scm ends here