diff mbox series

[bug#49889,4/5] gnu: Add gerbil-srfi-54.

Message ID aeaee21194336c39b3300acd62bbf118278d8d33.1628172101.git.public@yoctocell.xyz
State New
Headers show
Series Add build system for Gerbil Scheme | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Aug. 5, 2021, 2:10 p.m. UTC
* gnu/packages/gerbil.scm (gerbil-srfi-54): New variable.
---
 gnu/packages/gerbil.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gerbil.scm b/gnu/packages/gerbil.scm
index 90559e9ea2..aee5da60cd 100644
--- a/gnu/packages/gerbil.scm
+++ b/gnu/packages/gerbil.scm
@@ -139,3 +139,28 @@  is that Gerbil modules are single instantiation, supporting high performance ahe
 time compilation and compiled macros.")
     (home-page "https://cons.io")
     (license (list license:lgpl2.1 license:asl2.0))))
+
+(define-public gerbil-srfi-54
+  ;; No releases; commit from 2019-01-13.
+  (let ((commit "a7db045ad3f150b5dde79c3320c34d8ac3589525")
+        (revision "0"))
+  (package
+    (name "gerbil-srfi-54")
+    (version (git-version "0.0.0" revision commit))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/hckiang/srfi-54")
+                    (commit commit)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0k1ddfhvbmf9njxm1ybs61n9kpzjvha2j63mf756r7b3x5rk51b0"))))
+    (build-system gerbil-build-system)
+    (home-page "https://github.com/hckiang/srfi-54")
+    (synopsis "SRFI-54 for Gerbil Scheme")
+    (description "This package provides SRFI-54 for Gerbil Scheme.
+The implementation is exactly the same as the
+@uref{https://srfi.schemers.org/srfi-54/srfi-54.html, official
+reference documentation}.")
+    (license license:lgpl3+))))