mbox series

[bug#64150,00/24] Various changes to support updating the default ruby.

Message ID 87leghko6e.fsf@cbaines.net
Headers show
Series Various changes to support updating the default ruby. | expand

Message

Christopher Baines June 18, 2023, 11:23 a.m. UTC
I'm looking at updating the default ruby, and these changes update some
packages that might break, plus explicitly using ruby-2.7 in places to
reduce the dependencies on ruby.

Christopher Baines (24):
  gnu: texlive-hyphen-package: Explicitly use ruby-2.7.
  gnu: texlive-hyph-utf8: Explicitly use ruby-2.7.
  gnu: texlive-bin: Explicitly use ruby-2.7.
  gnu: qtbase: Explicitly use ruby-2.7.
  gnu: texlive-hyphen-package: Use pinned ruby-hydra-minimal.
  gnu: qtwebengine-5: Explicitly use ruby-2.7.
  gnu: utf8proc-2.7.0: Explicitly use ruby-2.7.
  gnu: webkitgtk: Explicitly use ruby-2.
  gnu: mkvtoolnix: Explicitly use ruby-2.7.
  gnu: ruby-yajl-ruby: Update to 1.4.3.
  gnu: ruby-tzinfo: Update to 2.0.6.
  gnu: ruby-test-unit: Update to 3.6.0.
  gnu: ruby-sucker-punch: Update to 3.1.0.
  gnu: ruby-shindo: Update to 0.3.10.
  gnu: ruby-rjb: Update to 1.6.7.
  gnu: ruby-range-compressor: Update to 1.2.0.
  gnu: ruby-pry-doc: Update to 1.4.0.
  gnu: ruby-powerpack: Update to 0.1.3.
  gnu: ruby-mkmf-lite: Update to 0.5.2.
  gnu: ruby-memory-profiler: Update to 1.0.1.
  gnu: ruby-hocon: Update to 1.4.0.
  gnu: ruby-debug-inspector: Update to 1.1.0.
  gnu: ruby-commander: Update to 4.6.0.
  gnu: bioruby: Update to 2.0.4.

 gnu/packages/bioinformatics.scm |  32 ++---
 gnu/packages/qt.scm             |   4 +-
 gnu/packages/rails.scm          |  25 ++--
 gnu/packages/ruby.scm           | 231 ++++++++++++++++++--------------
 gnu/packages/tex.scm            |   6 +-
 gnu/packages/textutils.scm      |   2 +-
 gnu/packages/video.scm          |   2 +-
 gnu/packages/webkit.scm         |   2 +-
 8 files changed, 165 insertions(+), 139 deletions(-)


base-commit: e4087930f3ad60918689be5f4bca4ce3e22429f5

Comments

Christopher Baines June 20, 2023, 9:20 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> I'm looking at updating the default ruby, and these changes update some
> packages that might break, plus explicitly using ruby-2.7 in places to
> reduce the dependencies on ruby.
>
> Christopher Baines (24):
>   gnu: texlive-hyphen-package: Explicitly use ruby-2.7.
>   gnu: texlive-hyph-utf8: Explicitly use ruby-2.7.
>   gnu: texlive-bin: Explicitly use ruby-2.7.
>   gnu: qtbase: Explicitly use ruby-2.7.
>   gnu: texlive-hyphen-package: Use pinned ruby-hydra-minimal.
>   gnu: qtwebengine-5: Explicitly use ruby-2.7.
>   gnu: utf8proc-2.7.0: Explicitly use ruby-2.7.
>   gnu: webkitgtk: Explicitly use ruby-2.
>   gnu: mkvtoolnix: Explicitly use ruby-2.7.
>   gnu: ruby-yajl-ruby: Update to 1.4.3.
>   gnu: ruby-tzinfo: Update to 2.0.6.
>   gnu: ruby-test-unit: Update to 3.6.0.
>   gnu: ruby-sucker-punch: Update to 3.1.0.
>   gnu: ruby-shindo: Update to 0.3.10.
>   gnu: ruby-rjb: Update to 1.6.7.
>   gnu: ruby-range-compressor: Update to 1.2.0.
>   gnu: ruby-pry-doc: Update to 1.4.0.
>   gnu: ruby-powerpack: Update to 0.1.3.
>   gnu: ruby-mkmf-lite: Update to 0.5.2.
>   gnu: ruby-memory-profiler: Update to 1.0.1.
>   gnu: ruby-hocon: Update to 1.4.0.
>   gnu: ruby-debug-inspector: Update to 1.1.0.
>   gnu: ruby-commander: Update to 4.6.0.
>   gnu: bioruby: Update to 2.0.4.
>
>  gnu/packages/bioinformatics.scm |  32 ++---
>  gnu/packages/qt.scm             |   4 +-
>  gnu/packages/rails.scm          |  25 ++--
>  gnu/packages/ruby.scm           | 231 ++++++++++++++++++--------------
>  gnu/packages/tex.scm            |   6 +-
>  gnu/packages/textutils.scm      |   2 +-
>  gnu/packages/video.scm          |   2 +-
>  gnu/packages/webkit.scm         |   2 +-
>  8 files changed, 165 insertions(+), 139 deletions(-)

QA hasn't quite finished testing this, but I think I checked everything
builds locally on x86_64-linux (at least after also updating
ruby-ptools).

I've now pushed to master as 53d80d04854f263e360d5f2b9e1d00ff5dad5227.