mbox series

[bug#51838,v9,00/41] guix: node-build-system: Support compiling add-ons with node-gyp.

Message ID 20220108084229.362642-1-philip@philipmcgrath.com
Headers show
Series guix: node-build-system: Support compiling add-ons with node-gyp. | expand

Message

Philip McGrath Jan. 8, 2022, 8:41 a.m. UTC
Ninth time's the charm? I hope so!

The only changes from v8 are:

  - In 03/41, I revised the docstring for 'jsonobject-update*' as discussed
    in <https://issues.guix.gnu.org/51838#411>;

  - In 05/41, I changed 'delete-dependencies' to accept strings, rather than
    regexps, and not to delete "peerDependencies", as discussed in
    <https://issues.guix.gnu.org/51838#410>;

  - In 06/41 through 41/41, I changed the arguments to 'delete-dependencies'
    accordingly, where applicable.

Liliana, I removed your "Signed-off-by" so as not to imply that you'd seen
these changes. I also added you as a co-author to 05/41, which seemed
appropriate. Of course, feel free to adjust as you like.

 -Philip

Philip McGrath (41):
  guix: node-build-system: Add delete-lockfiles phase.
  guix: node-build-system: Add implicit libuv input.
  guix: node-build-system: Add JSON utilities.
  guix: node-build-system: Add avoid-node-gyp-rebuild phase.
  guix: node-build-system: Add 'delete-dependencies' helper function.
  gnu: node-semver-bootstrap: Use 'delete-dependencies'.
  gnu: node-ms-bootstrap: Use 'delete-dependencies'.
  gnu: node-binary-search-bootstrap: Use 'delete-dependencies'.
  gnu: node-debug-bootstrap: Use 'delete-dependencies'.
  gnu: node-llparse-builder-bootstrap: Use 'delete-dependencies'.
  gnu: node-llparse-frontend-bootstrap: Use 'delete-dependencies'.
  gnu: node-llparse-bootstrap: Use 'delete-dependencies'.
  gnu: node-semver: Use 'delete-dependencies'.
  gnu: node-wrappy: Use 'delete-dependencies'.
  gnu: node-once: Use 'delete-dependencies'.
  gnu: node-irc-colors: Use 'delete-dependencies'.
  gnu: node-irc: Use 'delete-dependencies'.
  gnu: Add node-inherits.
  gnu: Add node-safe-buffer.
  gnu: Add node-string-decoder.
  gnu: Add node-readable-stream.
  gnu: Add node-nan.
  gnu: Add node-openzwave-shared.
  gnu: Add node-addon-api.
  gnu: Add node-sqlite3.
  gnu: Add node-file-uri-to-path.
  gnu: Add node-bindings.
  gnu: Add node-segfault-handler.
  gnu: Add node-ms.
  gnu: Add node-debug.
  gnu: Add node-serialport-binding-abstract.
  gnu: Add node-serialport-parser-delimiter.
  gnu: Add node-serialport-parser-readline.
  gnu: Add node-serialport-bindings.
  gnu: Add node-serialport-parser-regex.
  gnu: Add node-serialport-parser-ready.
  gnu: Add node-serialport-parser-inter-byte-timeout.
  gnu: Add node-serialport-parser-cctalk.
  gnu: Add node-serialport-parser-byte-length.
  gnu: Add node-serialport-stream.
  gnu: Add node-serialport.

 gnu/packages/node-xyz.scm        | 966 ++++++++++++++++++++++++++++++-
 gnu/packages/node.scm            |  63 +-
 gnu/packages/zwave.scm           |  64 ++
 guix/build-system/node.scm       |   9 +-
 guix/build/node-build-system.scm | 236 +++++++-
 5 files changed, 1277 insertions(+), 61 deletions(-)

Comments

Liliana Marie Prikler Jan. 8, 2022, 11:19 a.m. UTC | #1
Am Samstag, dem 08.01.2022 um 03:41 -0500 schrieb Philip McGrath:
> Ninth time's the charm? I hope so!
> 
> The only changes from v8 are:
> 
>   - In 03/41, I revised the docstring for 'jsonobject-update*' as
> discussed
>     in <https://issues.guix.gnu.org/51838#411>;
Misspelled UPDATES as UPDATERs, but otherwise fine.

>   - In 05/41, I changed 'delete-dependencies' to accept strings,
> rather than
>     regexps, and not to delete "peerDependencies", as discussed in
>     <https://issues.guix.gnu.org/51838#410>;
> 
>   - In 06/41 through 41/41, I changed the arguments to 'delete-
> dependencies' accordingly, where applicable.
Fair enough, I can live without regexps for now.

> Liliana, I removed your "Signed-off-by" so as not to imply that you'd
> seen these changes. I also added you as a co-author to 05/41, which
> seemed appropriate. Of course, feel free to adjust as you like.
As far as I can see 05/41 carries none of my intellectual property. 
All I did was adjust it to my changes in 03.

I'll look over the changes more closely later and apply them once I've
confirmed that that's everything.

Cheers
Philip McGrath Jan. 8, 2022, 3:33 p.m. UTC | #2
Hi,

On 1/8/22 06:19, Liliana Marie Prikler wrote:
> Am Samstag, dem 08.01.2022 um 03:41 -0500 schrieb Philip McGrath:
>> Liliana, I removed your "Signed-off-by" so as not to imply that you'd
>> seen these changes. I also added you as a co-author to 05/41, which
>> seemed appropriate. Of course, feel free to adjust as you like.
> As far as I can see 05/41 carries none of my intellectual property.
> All I did was adjust it to my changes in 03.

My intention was to acknowledge that the basic approach of 
'delete-dependencies' was your idea. But, again, whatever you like!

-Philip
Liliana Marie Prikler Jan. 9, 2022, 1:19 a.m. UTC | #3
Am Samstag, dem 08.01.2022 um 10:33 -0500 schrieb Philip McGrath:
> My intention was to acknowledge that the basic approach of 
> 'delete-dependencies' was your idea. But, again, whatever you like!
That hardly counts as intellectual property in my opinion, it's not
like I revolutionized anything in the scope of Guix.

The new node-build-system is live now, so you can rewrite JSON and
delete dependencies as much as you want on master.  Please allow for
other users to actually make use of it before writing up your next
proposal.  We'll only be able to see our shortcomings by having a large
number of people try it in the real world.

Thanks and good night :)