diff mbox series

[bug#51838,v9,30/41] gnu: Add node-debug.

Message ID 20220108084229.362642-31-philip@philipmcgrath.com
State Accepted
Headers show
Series guix: node-build-system: Support compiling add-ons with node-gyp. | expand

Commit Message

Philip McGrath Jan. 8, 2022, 8:42 a.m. UTC
* gnu/packages/node-xyz.scm (node-debug): New variable.
---
 gnu/packages/node-xyz.scm | 45 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 6142254c35..3be2b93b31 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -985,3 +985,48 @@  (define-public node-ms
 equivalent milliseconds is returned.
 @end itemize")
     (license license:expat)))
+
+(define-public node-debug
+  (package
+    (name "node-debug")
+    (version "4.3.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/debug-js/debug")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ji0dmdl2xkgxqxvd6xjy7k3mmknmhvqjgc40vyly9ka1mpf20vb"))))
+    (inputs
+     (list node-ms))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies `("brfs"
+                                    "browserify"
+                                    "coveralls"
+                                    "istanbul"
+                                    "karma"
+                                    "karma-browserify"
+                                    "karma-chrome-launcher"
+                                    "karma-mocha"
+                                    "mocha"
+                                    "mocha-lcov-reporter"
+                                    "xo"
+                                    "supports-color")))))
+       #:tests? #f))
+    (home-page "https://github.com/debug-js/debug")
+    (synopsis "Lightweight debugging utility for Node.js and the browser")
+    (description "A tiny JavaScript debugging utility modelled after Node.js
+core's debugging technique.  orks in Node.js and web browsers.
+
+The @code{debug} module exposes a function; simply pass this function the name
+of your module, and it will return a decorated version of @code{console.error}
+for you to pass debug statements to.  This will allow you to toggle the debug
+output for different parts of your module as well as the module as a whole.")
+    (license license:expat)))