diff mbox series

[bug#51838,v9,27/41] gnu: Add node-bindings.

Message ID 20220108084229.362642-28-philip@philipmcgrath.com
State Accepted
Headers show
Series guix: node-build-system: Support compiling add-ons with node-gyp. | expand

Commit Message

Philip McGrath Jan. 8, 2022, 8:42 a.m. UTC
* gnu/packages/node-xyz.scm (node-bindings): New variable.
---
 gnu/packages/node-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index c35ae10990..70dc08debe 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -884,3 +884,29 @@  (define-public node-file-uri-to-path
 URI to a file path.  It accepts a @code{file:} URI and returns a file path
 suitable for use with the @code{fs} module functions.")
     (license license:expat)))
+
+(define-public node-bindings
+  (package
+    (name "node-bindings")
+    (version "1.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/TooTallNate/node-bindings")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "100gp6kpjvd4j1dqnp0sbjr1hqx5mz7r61q9qy527jyhk9mj47wk"))))
+    (inputs
+     (list node-file-uri-to-path))
+    (build-system node-build-system)
+    (arguments
+     ;; there are no tests
+     `(#:tests? #f))
+    (home-page "https://github.com/TooTallNate/node-bindings")
+    (synopsis "Help for loading your native module's @code{.node} file")
+    (description "This is a helper module for authors of Node.js native addon
+modules.  It is basically the ``swiss army knife'' of @code{require()}ing your
+native module's @code{.node} file.")
+    (license license:expat)))