[bug#33186,2/7] services: kmscon: Do not switch to vt at start.

Message ID 20181028124043.21773-3-m.othacehe@gmail.com
State Accepted
Headers show
Series Preliminary installer work | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Mathieu Othacehe Oct. 28, 2018, 12:40 p.m. UTC
* gnu/services/base.scm (kmscon-service-type): Add "--no-switchvt" to kmscon
command to prevent a switch to virtual terminal every time a new kmscon
service is spawned.
---
 gnu/services/base.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Ludovic Courtès Nov. 6, 2018, 3:35 p.m. UTC | #1
Mathieu Othacehe <m.othacehe@gmail.com> skribis:

> * gnu/services/base.scm (kmscon-service-type): Add "--no-switchvt" to kmscon
> command to prevent a switch to virtual terminal every time a new kmscon
> service is spawned.

Perhaps move this explanation as a comment.

Otherwise LGTM, thanks!
Mathieu Othacehe Nov. 7, 2018, 9:17 a.m. UTC | #2
> Perhaps move this explanation as a comment.
>
> Otherwise LGTM, thanks!

Fixed and pushed as f4e8bc5f250bcf5f7daf5eb28b0b9f1131e4ac61.

Thanks,

Mathieu

Patch

diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index 47c7d8bb2..4c341309b 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -2057,6 +2057,7 @@  This service is not part of @var{%base-services}."
          #~(list
             #$(file-append kmscon "/bin/kmscon") "--login"
             "--vt" #$virtual-terminal
+            "--no-switchvt"
             #$@(if hardware-acceleration? '("--hwaccel") '())
             "--" #$login-program #$@login-arguments))