[bug#33186,0/7] Preliminary installer work

Message ID 20181028123511.21265-1-m.othacehe@gmail.com
Headers show
Series Preliminary installer work | expand

Message

Mathieu Othacehe Oct. 28, 2018, 12:35 p.m. UTC
Hello!

Here are some patches required for the upcoming graphical installer.  As I
patched the glibc they require to rebuild the world, thus I would like to push
them on a wip-newt-installer branch.

By the way, is this approach (sending series to review and push them on a wip
branch) ok, or should I proceed differently ?

Another precision, I'd like the installer to support internationalization.
So working with raw linux terminal is excluded. After some resarchs, I see
only two options:

* Using bterm[1] like D-I (Debian Installer) and Anaconda. It is a framebuffer
  terminal supporting multibyte locales.
* Use kmscon[2], a terminal emulator based on linux KMS.

Even if both of them are unmaintained, I prefer kmscon which seems stable
enough and has nice features, such as font rendering with pango,
internationalized keyboard handling with libxkbcommon, hardware accelerated
rendering and is already packaged as a service for GuixSD.

What do you think of this choice?

Thank you,

Mathieu

[1]: https://packages.debian.org/en/jessie/bogl-bterm
[2]: https://wiki.archlinux.org/index.php/KMSCON

Mathieu Othacehe (7):
  gnu: Add guile-newt.
  services: kmscon: Do not switch to vt at start.
  services: kmscon: Add an auto-login option.
  gnu: glibc: Export supported locales.
  gnu: terminals: Change libtsm and kmscon repositories.
  gnu: slang: Use a correct location for terminfo dirs.
  gnu: python-3.6: Disable congestion test.

 doc/guix.texi                                 |   6 +-
 gnu/local.mk                                  |   2 +
 gnu/packages/base.scm                         |   6 +-
 gnu/packages/guile.scm                        |  43 ++++-
 .../patches/glibc-supported-locales.patch     |  31 +++
 .../python-disable-congestion-test.patch      |  60 ++++++
 gnu/packages/python.scm                       |   1 +
 gnu/packages/slang.scm                        |  14 +-
 gnu/packages/terminals.scm                    | 176 ++++++++++--------
 gnu/services/base.scm                         |  10 +-
 10 files changed, 260 insertions(+), 89 deletions(-)
 create mode 100644 gnu/packages/patches/glibc-supported-locales.patch
 create mode 100644 gnu/packages/patches/python-disable-congestion-test.patch