[bug#33186,1/7] gnu: Add guile-newt.

Message ID 20181028124043.21773-2-m.othacehe@gmail.com
State Accepted
Headers show
Series Preliminary installer work | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Mathieu Othacehe Oct. 28, 2018, 12:40 p.m. UTC
* gnu/packages/guile.scm (guile-newt): New variable.
---
 gnu/packages/guile.scm | 43 +++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 42 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Nov. 6, 2018, 3:34 p.m. UTC | #1
Hello!

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

> * gnu/packages/guile.scm (guile-newt): New variable.

[...]

> +       '(#:make-flags
> +         '("GUILE_AUTO_COMPILE=0")        ; to prevent guild errors

Actually warnings.  :-)

> +         #:phases
> +         (modify-phases %standard-phases
> +          (add-after 'unpack 'bootstrap
> +            (lambda _
> +              (zero? (system* "autoreconf" "-vfi")))))))

This phase shouldn’t be necessary.

Otherwise LGTM, thanks!

Ludo’.
Mathieu Othacehe Nov. 7, 2018, 9:12 a.m. UTC | #2
Hey Ludo,

Thanks for reviewing the whole serie :)

> This phase shouldn’t be necessary.
>
> Otherwise LGTM, thanks!

Fixed and pushed as 581720bc7468374a61bedc000b3a80d5ea2d9336.

Mathieu

Patch

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9e3300337..ba7aa63ad 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -12,7 +12,7 @@ 
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
 ;;; Copyright © 2017 David Thompson <davet@gnu.org>
-;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2017, 2018 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -68,6 +68,7 @@ 
   #:use-module (gnu packages maths)
   #:use-module (gnu packages image)
   #:use-module (gnu packages version-control)
+  #:use-module (gnu packages slang)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages networking)
@@ -2286,4 +2287,44 @@  using S-expressions.")
 tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
     (license license:gpl3+)))
 
+;; There has not been any release yet.
+(define-public guile-newt
+  (let ((commit "596ad760bee1be419d71271732f0f30eaee55143")
+        (revision "0"))
+    (package
+      (name "guile-newt")
+      (version (string-append "0-" revision "." (string-take commit 9)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://gitlab.com/mothacehe/guile-newt")
+                      (commit commit)))
+                (file-name (string-append name "-" version "-checkout"))
+                (sha256
+                 (base32
+                  "18qqbi0bc7vp2vlrhib3p3wwgn7wrlv5728dn0avirhw4fxxivnf"))))
+      (build-system gnu-build-system)
+      (arguments
+       '(#:make-flags
+         '("GUILE_AUTO_COMPILE=0")        ; to prevent guild errors
+         #:phases
+         (modify-phases %standard-phases
+          (add-after 'unpack 'bootstrap
+            (lambda _
+              (zero? (system* "autoreconf" "-vfi")))))))
+      (inputs
+       `(("guile" ,guile-2.2)
+         ("newt" ,newt)))
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)
+         ("pkg-config" ,pkg-config)))
+      (synopsis "Guile bindings to Newt")
+      (description
+       "This package provides bindings for Newt, a programming library for
+color text mode, widget based user interfaces.  The bindings are written in pure
+Scheme by using Guile’s foreign function interface.")
+      (home-page "https://gitlab.com/mothacehe/guile-newt")
+      (license license:gpl3+))))
+
 ;;; guile.scm ends here