Message ID | 20190127170820.28937-15-mail@cbaines.net |
---|---|
State | Accepted |
Headers | show |
Series | Add ruby-rubocop and dependencies. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
Christopher Baines <mail@cbaines.net> writes:
> * gnu/packages/ruby.scm (ruby-rubocop): New variable.
LGTM!
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm index 9026251626..6f9ad43c53 100644 --- a/gnu/packages/ruby.scm +++ b/gnu/packages/ruby.scm @@ -4083,6 +4083,36 @@ post, delete.") (home-page "https://github.com/rest-client/rest-client") (license license:expat))) +(define-public ruby-rubocop + (package + (name "ruby-rubocop") + (version "0.63.1") + (source + (origin + (method url-fetch) + (uri (rubygems-uri "rubocop" version)) + (sha256 + (base32 + "1pq00qwlmcv52dbhgbk534ggwn1ny9k3sq3vfb1zk3r4psnqz2jy")))) + (build-system ruby-build-system) + (arguments + '(;; No included tests + #:tests? #f)) + (propagated-inputs + `(("ruby-parser" ,ruby-parser) + ("ruby-powerpack" ,ruby-powerpack) + ("ruby-rainbow" ,ruby-rainbow) + ("ruby-ruby-progressbar" ,ruby-ruby-progressbar) + ("ruby-parallel" ,ruby-parallel) + ("ruby-jaro-winkler" ,ruby-jaro-winkler) + ("ruby-unicode-display-width" ,ruby-unicode-display-width))) + (synopsis "Ruby code style checking tool") + (description + "@code{rubocop} is a Ruby code style checking tool. It aims to enforce +the community-driven Ruby Style Guide.") + (home-page "https://github.com/rubocop-hq/rubocop") + (license license:expat))) + (define-public ruby-contest (package (name "ruby-contest")