diff mbox series

[bug#53765,14/17] gnu: Add clojure-com-cognitect-aws-endpoints.

Message ID 87fsoz32b3.fsf@reilysiegel.com
State New
Headers show
Series Remove limitations on clojure-tools | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Reily Siegel Feb. 4, 2022, 12:25 a.m. UTC
* gnu/packages/clojure.scm (clojure-com-cognitect-aws-endpoints): New variable.
---
 gnu/packages/clojure.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

M Feb. 7, 2022, 7:53 p.m. UTC | #1
Reily Siegel schreef op do 03-02-2022 om 19:25 [-0500]:
> +(define-public clojure-com-cognitect-aws-endpoints
> +  (package
> +    (inherit clojure-com-cognitect-aws-api)
> +    (name "clojure-com-cognitect-aws-endpoints")
> +    (version "1.1.12.136")
> +    (source (origin
> +              (method url-fetch)
> +              ;; This JAR contains only data files.
> +              (uri (string-append "https://repo1.maven.org/maven2/"
> +                                  "com/cognitect/aws/endpoints/"
> +                                  version "/endpoints-"
> +                                  version "-sources.jar"))
> +              (sha256
> +               (base32
> +                "15irzbnr0gp5pf0nh9vws6kyzjsbqshiqm9b8frjgsnizvqw0jqj"))))
> +    [...]
> +    (license license:asl2.0)))

I downloaded the source code. The hash matches.
It does indeed appear to be pure data.
However, I don't see any indication of it being ASL2.0
-- <https://mvnrepository.com/artifact/com.cognitect.aws/endpoints>
says it's Apache 2.0, but that seems in conflict with 4.(a) of the
ASL2.0:

4. Redistribution.   You may reproduce and distribute copies [...],
provided that You meet the following conditions:

a. You must give any other recipients of the Work or Derivative Works a
copy of this License; and [...]

so the license information on Maven doesn't seem convincing evidence.

It might be ASL2.0 after all, but stronger evidence is needed.

Greetings,
Maxime.
Reily Siegel Feb. 7, 2022, 8:01 p.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> However, I don't see any indication of it being ASL2.0
> -- <https://mvnrepository.com/artifact/com.cognitect.aws/endpoints>
> says it's Apache 2.0, but that seems in conflict with 4.(a) of the
> ASL2.0:
The pom.xml file on Maven links to
http://www.apache.org/licenses/LICENSE-2.0.txt, is this sufficient to
meet the terms of the license? If not, I can reach out to people from
cognitect, but may or may not be able to get a response.
diff mbox series

Patch

diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index b99ec139da..f4b389f7b0 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -300,6 +300,30 @@  (define-public clojure-com-cognitect-aws-api
 for every operation on every service.")
     (license license:asl2.0)))
 
+(define-public clojure-com-cognitect-aws-endpoints
+  (package
+    (inherit clojure-com-cognitect-aws-api)
+    (name "clojure-com-cognitect-aws-endpoints")
+    (version "1.1.12.136")
+    (source (origin
+              (method url-fetch)
+              ;; This JAR contains only data files.
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "com/cognitect/aws/endpoints/"
+                                  version "/endpoints-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "15irzbnr0gp5pf0nh9vws6kyzjsbqshiqm9b8frjgsnizvqw0jqj"))))
+    (native-inputs '())
+    (propagated-inputs '())
+    (arguments
+     '(#:doc-dirs '()
+       ;; This package contains only data, no code to test.
+       #:tests? #f))
+    (synopsis "Endpoint data for @code{aws-api}")
+    (license license:asl2.0)))
+
 (define-public clojure-com-cognitect-http-client
   (package
     (name "clojure-com-cognitect-aws-api")