[bug#56752,15/27] gnu: rust-once-cell-1: Update to 1.13.0.
Commit Message
* gnu/packages/crates-io.scm (rust-once-cell-1): Update to 1.13.0.
---
gnu/packages/crates-io.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)
Comments
On 24-07-2022 23:36, Aleksandr Vityazev wrote:
> (("rust-atomic-polyfill" ,rust-atomic-polyfill-0.1)
> - ("rust-parking-lot" ,rust-parking-lot-0.11))
> + ("rust-parking-lot-core" ,rust-parking-lot-core-0.9))
> #:cargo-development-inputs
> - (("rust-crossbeam-utils" ,rust-crossbeam-utils-0.7)
> + (("rust-crossbeam-utils" ,rust-crossbeam-utils-0.8)
This is another one of those overly-strict packages.
Greetings,
Maxime.
@@ -39276,7 +39276,7 @@ (define-public rust-onig-sys-69.2
(define-public rust-once-cell-1
(package
(name "rust-once-cell")
- (version "1.9.0")
+ (version "1.13.0")
(source
(origin
(method url-fetch)
@@ -39284,14 +39284,15 @@ (define-public rust-once-cell-1
(file-name
(string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1mfqhrsgi368x92bwnq3vi3p5nv0n1qlrn69gfflhvkfkxfm2cns"))))
+ (base32 "1qfqvgnwfzzwxd13ybvplzshaqwnjnna9ghcn0zgijaq0zixp9hq"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
+ `(#:skip-build? #t
+ #:cargo-inputs
(("rust-atomic-polyfill" ,rust-atomic-polyfill-0.1)
- ("rust-parking-lot" ,rust-parking-lot-0.11))
+ ("rust-parking-lot-core" ,rust-parking-lot-core-0.9))
#:cargo-development-inputs
- (("rust-crossbeam-utils" ,rust-crossbeam-utils-0.7)
+ (("rust-crossbeam-utils" ,rust-crossbeam-utils-0.8)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-regex" ,rust-regex-1))))
(home-page "https://github.com/matklad/once_cell")