diff mbox series

[bug#56752,05/27] gnu: Add rust-swayipc-types-1.

Message ID 587748e23702659d89ca33b7bc9f806939ae5950.1658698210.git.avityazev@posteo.org
State New
Headers show
Series [bug#56752,01/27] gnu: Add rust-rt-format-0.3. | expand

Commit Message

Aleksandr Vityazev July 24, 2022, 9:33 p.m. UTC
* gnu/packages/crates-io.scm (rust-swayipc-types-1): New variable.
---
 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

M July 24, 2022, 9:37 p.m. UTC | #1
On 24-07-2022 23:33, Aleksandr Vityazev wrote:
> +  (package
> +    (name "rust-swayipc-types")
> +    (version "1.1.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "swayipc-types" version))
> +       (file-name (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "11p2jj081f7bw2rc6xqvw3y8bdraqqrmm3vsvq5mx7ds00r35jiq"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +     `(#:skip-build? #t
> +       #:cargo-inputs
> +       (("rust-serde" ,rust-serde-1)
> +        ("rust-serde-json" ,rust-serde-json-1)
> +        ("rust-thiserror" ,rust-thiserror-1))))

Warning: this is one of those overly picky packages that pin the minor 
version of rust-serde & rust-serde-json & rust-thiserror, you will have 
to patch the Cargo.toml to relax it a bit, otherwise it will break with 
future updates to rust-swayipc-types. Alternatively, you can wait for 
antioxidant.

Greetings,
Maxime.
M July 24, 2022, 9:42 p.m. UTC | #2
On 24-07-2022 23:37, Maxime Devos wrote:
> Warning: this is one of those overly picky packages that pin the minor 
> version of rust-serde & rust-serde-json & rust-thiserror, you will 
> have to patch the Cargo.toml to relax it a bit, otherwise it will 
> break with future updates to rust-swayipc-types. Alternatively, you 
> can wait for antioxidant. 
(Also check for the other packages)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 09d0234fc8..2974bf344a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -60064,6 +60064,32 @@  (define-public rust-swayipc-command-builder-0.1
 executed by swayipc.")
     (license license:expat)))
 
+(define-public rust-swayipc-types-1
+  (package
+    (name "rust-swayipc-types")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "swayipc-types" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "11p2jj081f7bw2rc6xqvw3y8bdraqqrmm3vsvq5mx7ds00r35jiq"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-thiserror" ,rust-thiserror-1))))
+    (home-page "https://github.com/jaycefayne/swayipc-rs")
+    (synopsis "Library containing Type defintions from sway's IPC interface")
+    (description
+     "This package provides a library containing Type defintions from sway's IPC
+interface.")
+    (license license:expat)))
+
 (define-public rust-swc-1
   (package
     (name "rust-swc")