diff mbox series

[bug#56752,06/27] gnu: Add rust-swayipc-3.

Message ID 22132e72eed5efc4cfbd5bec63c21d07bf69f206.1658698210.git.avityazev@posteo.org
State New
Headers show
Series [bug#56752,01/27] gnu: Add rust-rt-format-0.3. | expand

Commit Message

Aleksandr Vityazev July 24, 2022, 9:33 p.m. UTC
* gnu/packages/crates-io.scm (rust-swayipc-3): New variable.
---
 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

M July 24, 2022, 9:35 p.m. UTC | #1
On 24-07-2022 23:33, Aleksandr Vityazev wrote:
> +    (build-system cargo-build-system)
> +    (arguments
> +     `(#:skip-build? #t
> +       #:cargo-inputs
> +       (("rust-serde" ,rust-serde-1)
> +        ("rust-serde-json" ,rust-serde-json-1)
> +        ("rust-swayipc-types" ,rust-swayipc-types-1))))
> +    (home-page"https://github.com/jaycefayne/swayipc-rs")
> +    (synopsis "Library for controlling sway through its IPC interface")
> +    (description
> +     "This package provides a library for controlling sway through its IPC
> +interface.")
> +    (license license:expat)))
> +

We already have that package, try "guix edit rust-swayipc". No need to 
override the description, home-page, etc.

Greetings,
Maxime.
M July 24, 2022, 9:42 p.m. UTC | #2
On 24-07-2022 23:33, Aleksandr Vityazev wrote:
> +(define-public rust-swayipc-3
> +  (package
> +    (name "rust-swayipc")
> +    (version "3.0.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "swayipc" version))
> +       (file-name (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "1v6arq79b72wm938yvb72j8np04n4ia9r78idg2ffcczp8mpxk20"))))

Looks like this can not legally be distributed as-is -- from the expat 
license:

> Permission is hereby granted, free of charge, to any person obtaining 
> a copy of this software and associated documentation files (the 
> "Software"), to deal in the Software without restriction, including 
> without limitation the rights to use, copy, modify, merge, publish, 
> distribute, sublicense, and/or sell copies of the Software, and to 
> permit persons to whom the Software is furnished to do so, ___subject 
> to the following conditions___:
>
> __The above copyright notice and this permission notice shall be 
> included in all copies or substantial portions of the Software.___
>
(emphasis mine).

This notice is missing from the tarball I've downloaded.  The other 
packages might have the same issue, please check.

Greetings,
Maxime
Aleksandr Vityazev July 24, 2022, 10:08 p.m. UTC | #3
On 2022-07-24, 23:35 +0200, Maxime Devos <maximedevos@telenet.be> wrote:

> On 24-07-2022 23:33, Aleksandr Vityazev wrote:
>> +    (build-system cargo-build-system)
>> +    (arguments
>> +     `(#:skip-build? #t
>> +       #:cargo-inputs
>> +       (("rust-serde" ,rust-serde-1)
>> +        ("rust-serde-json" ,rust-serde-json-1)
>> +        ("rust-swayipc-types" ,rust-swayipc-types-1))))
>> +    (home-page"https://github.com/jaycefayne/swayipc-rs")
>> +    (synopsis "Library for controlling sway through its IPC interface")
>> +    (description
>> +     "This package provides a library for controlling sway through its IPC
>> +interface.")
>> +    (license license:expat)))
>> +
>
> We already have that package, try "guix edit rust-swayipc". No need to override the description,
> home-page, etc.

We have rust-swayipc-2, and I have not seen the newer version inherited
from the older one. In this case, we can add inheritance for
rust-swayipc-2.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2974bf344a..01ca45349d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -60019,6 +60019,32 @@  (define-public rust-swaybar-types-3
 Rust.")
     (license license:expat)))
 
+(define-public rust-swayipc-3
+  (package
+    (name "rust-swayipc")
+    (version "3.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "swayipc" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1v6arq79b72wm938yvb72j8np04n4ia9r78idg2ffcczp8mpxk20"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-swayipc-types" ,rust-swayipc-types-1))))
+    (home-page "https://github.com/jaycefayne/swayipc-rs")
+    (synopsis "Library for controlling sway through its IPC interface")
+    (description
+     "This package provides a library for controlling sway through its IPC
+interface.")
+    (license license:expat)))
+
 (define-public rust-swayipc-2
   (package
     (name "rust-swayipc")