From a528b757461e44693058515728192f9a7026f5ef Mon Sep 17 00:00:00 2001
From: Carlo Zancanaro <carlo@zancanaro.id.au>
Date: Mon, 25 Feb 2019 16:41:22 +1100
Subject: [PATCH] gnu: Add kawa.
To: guix-patches@gnu.org
* gnu/packages/scheme.scm (kawa): New variable.
---
gnu/packages/scheme.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)
@@ -31,7 +31,7 @@
#:use-module (gnu packages)
#:use-module ((guix licenses)
#:select (gpl2+ lgpl2.0+ lgpl2.1+ lgpl3+ asl2.0 bsd-3
- cc-by-sa4.0 non-copyleft))
+ cc-by-sa4.0 non-copyleft expat))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -69,6 +69,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages gl)
#:use-module (gnu packages libedit)
+ #:use-module (gnu packages java)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match))
@@ -1245,3 +1246,32 @@ multilingual support are some of the goals. Gauche comes with a package
manager/installer @code{gauche-package} which can download, compile, install
and list gauche extension packages.")
(license bsd-3)))
+
+(define-public kawa
+ (package
+ (name "kawa")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.gnu.org/pub/gnu/kawa/kawa-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1k9qpydc64ar4aqyg3q7jmmxy503ayj85227qfhc5n6ngchqavhy"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-build? #f
+ #:parallel-tests? #f))
+ (inputs
+ `(("icedtea" ,icedtea-8 "jdk")))
+ (home-page "https://www.gnu.org/software/kawa/")
+ (synopsis "Scheme on the Java Virtual machine")
+ (description "Kawa is an implementation of Scheme for the Java Virtual
+Machine. It combines the benefits of dynamic scripting languages (minimal
+boiler-plate, fast to start up, REPL) with the benefits of traditional
+compiled languages (fast execution, static error detection, modularity,
+zero-overhead Java integration). Kawa also provides a framework for
+implementing other programming languages on the Java platform.")
+ (license expat)))
--
2.21.0