[bug#33479] gnu: ghc-network: Update to 2.8.0.0

Message ID 20181124043222.10708-1-brettg@posteo.net
State Accepted
Headers show
Series [bug#33479] gnu: ghc-network: Update to 2.8.0.0 | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Brett Gilio Nov. 24, 2018, 4:32 a.m. UTC
---
 gnu/packages/haskell.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Nov. 24, 2018, 9:32 p.m. UTC | #1
Brett Gilio <brettg@posteo.net> skribis:

> ---
>  gnu/packages/haskell.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
> index 0a90ac523..5cd746b36 100644
> --- a/gnu/packages/haskell.scm
> +++ b/gnu/packages/haskell.scm
> @@ -4264,7 +4264,7 @@ interface.")
>  (define-public ghc-network
>    (package
>      (name "ghc-network")
> -    (version "2.6.3.6")
> +    (version "2.8.0.0")

I tried building everything ‘guix refresh -l ghc-network’ reports and
got this:

--8<---------------cut here---------------start------------->8---
[14 of 52] Compiling Network.TLS.Util.ASN1 ( Network/TLS/Util/ASN1.hs, dist/build/Network/TLS/Util/ASN1.o )

Network/TLS/Util/ASN1.hs:16:1: error:
    Bad interface file: /gnu/store/g10iyg7k77lwi1sy76x9ivxspdcdn417-ghc-asn1-types-0.3.2/lib/ghc-8.4.3/asn1-types-0.3.2/Data/ASN1/Types.hi
        Something is amiss; requested module  asn1-types-0.3.2:Data.ASN1.Types differs from name found in the interface file asn1-types-0.3.2:Data.ASN1.Types (if these names look the same, try again with -dppr-debug)
   |
16 | import Data.ASN1.Types (fromASN1, toASN1, ASN1Object)
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Network/TLS/Util/ASN1.hs:17:1: error:
    Bad interface file: /gnu/store/0v8mna962b2r902l41rkdwslp6iwcfzr-ghc-asn1-encoding-0.9.5/lib/ghc-8.4.3/asn1-encoding-0.9.5/Data/ASN1/Encoding.hi
        Something is amiss; requested module  asn1-encoding-0.9.5:Data.ASN1.Encoding differs from name found in the interface file asn1-encoding-0.9.5:Data.ASN1.Encoding (if these names look the same, try again with -dppr-debug)
   |
17 | import Data.ASN1.Encoding (decodeASN1', encodeASN1')
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Network/TLS/Util/ASN1.hs:18:1: error:
    Bad interface file: /gnu/store/0v8mna962b2r902l41rkdwslp6iwcfzr-ghc-asn1-encoding-0.9.5/lib/ghc-8.4.3/asn1-encoding-0.9.5/Data/ASN1/BinaryEncoding.hi
        Something is amiss; requested module  asn1-encoding-0.9.5:Data.ASN1.BinaryEncoding differs from name found in the interface file asn1-encoding-0.9.5:Data.ASN1.BinaryEncoding (if these names look the same, try again with -dppr-debug)
   |
18 | import Data.ASN1.BinaryEncoding (DER(..))
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Backtrace: 
           4 (primitive-load "/gnu/store/igjyba1xhv796ph1mnlr2fm2fdk…")
In ice-9/eval.scm:
   191:35  3 (_ _)
In srfi/srfi-1.scm:
    640:9  2 (for-each #<procedure 94e3e0 at /gnu/store/avr240b3zz4…> …)
In /gnu/store/avr240b3zz4606kpijnn7s1dvcavm495-module-import/guix/build/gnu-build-system.scm:
   799:31  1 (_ _)
In /gnu/store/avr240b3zz4606kpijnn7s1dvcavm495-module-import/guix/build/utils.scm:
    616:6  0 (invoke _ . _)

/gnu/store/avr240b3zz4606kpijnn7s1dvcavm495-module-import/guix/build/utils.scm:616:6: In procedure invoke:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "runhaskell" arguments: ("Setup.hs" "build") exit-status: 1 term-signal: #f stop-signal: #f] 98bd40>)'.
builder for `/gnu/store/c4w8iakyhh9zwbsa84zz2zmaqraxfajx-ghc-tls-1.4.1.drv' failed with exit code 1
--8<---------------cut here---------------end--------------->8---

Could you take a look?  In general GHC libraries are tightly coupled so
we must really test all the dependent of a package when updating it.

Also, could you please provide a commit log that matches our
conventions?  (See ‘git log’ for some examples.)

Thank you,
Ludo’.
Brett Gilio Dec. 5, 2019, 12:40 a.m. UTC | #2
Brett Gilio <brettg@posteo.net> writes:

> ---
>  gnu/packages/haskell.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
> index 0a90ac523..5cd746b36 100644
> --- a/gnu/packages/haskell.scm
> +++ b/gnu/packages/haskell.scm
> @@ -4264,7 +4264,7 @@ interface.")
>  (define-public ghc-network
>    (package
>      (name "ghc-network")
> -    (version "2.6.3.6")
> +    (version "2.8.0.0")
>      (outputs '("out" "doc"))
>      (source
>       (origin
> @@ -4275,7 +4275,7 @@ interface.")
>               ".tar.gz"))
>         (sha256
>          (base32
> -         "198mam7ahny48p9fajznbqq16a8ya2gw0xm3gnm1si1rmc4hdplv"))))
> +         "00skcish0xmm67ax999nv1nll9rm3gqmn92099iczd73nxl55468"))))
>      (build-system haskell-build-system)
>      ;; The regression tests depend on an unpublished module.
>      (arguments `(#:tests? #f))

This is a historical bug report and is no longer relevant. It can be
closed.
Efraim Flashner Dec. 5, 2019, 8:35 a.m. UTC | #3
close bug

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0a90ac523..5cd746b36 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4264,7 +4264,7 @@  interface.")
 (define-public ghc-network
   (package
     (name "ghc-network")
-    (version "2.6.3.6")
+    (version "2.8.0.0")
     (outputs '("out" "doc"))
     (source
      (origin
@@ -4275,7 +4275,7 @@  interface.")
              ".tar.gz"))
        (sha256
         (base32
-         "198mam7ahny48p9fajznbqq16a8ya2gw0xm3gnm1si1rmc4hdplv"))))
+         "00skcish0xmm67ax999nv1nll9rm3gqmn92099iczd73nxl55468"))))
     (build-system haskell-build-system)
     ;; The regression tests depend on an unpublished module.
     (arguments `(#:tests? #f))