diff mbox series

[bug#63004,2/2] gnu: ldc-bootstrap: Don't depend on tzdata.

Message ID 8ba08c4d2a7948431e72cd32466b1526fed35f56.1682110198.git.leo@famulari.name
State New
Headers show
Series [bug#63004,1/2] build-system/cmake: Add support for the #:disallowed-references key. | expand

Commit Message

Leo Famulari April 21, 2023, 8:49 p.m. UTC
* gnu/packages/dlang.scm (ldc-bootstrap)[inputs]: Remove tzdata.
[native-inputs]: Add tzdata-for-tests.
[arguments]: Forbid references to tzdata-for-tests.
---
 gnu/packages/dlang.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès May 6, 2023, 3:16 p.m. UTC | #1
Hi Leo,

The ‘cmake-build-system’ was pushed as
3b5b6683037dfb8f02d04ad3e6c2f04062db9a16 (a useful improvement).

The ‘ldc-bootstrap’ change LGTM!

Ludo’.
Josselin Poiret May 17, 2023, 9:26 p.m. UTC | #2
Hi Leo,

Leo Famulari <leo@famulari.name> writes:

> * gnu/packages/dlang.scm (ldc-bootstrap)[inputs]: Remove tzdata.
> [native-inputs]: Add tzdata-for-tests.
> [arguments]: Forbid references to tzdata-for-tests.

LGTM, applied as d19c7c2791dc01d678ec017ad83868d5629b53f6.

Best,
Leo Famulari May 18, 2023, 4:59 p.m. UTC | #3
On Wed, May 17, 2023 at 11:26:32PM +0200, Josselin Poiret wrote:
> Hi Leo,
> 
> Leo Famulari <leo@famulari.name> writes:
> 
> > * gnu/packages/dlang.scm (ldc-bootstrap)[inputs]: Remove tzdata.
> > [native-inputs]: Add tzdata-for-tests.
> > [arguments]: Forbid references to tzdata-for-tests.
> 
> LGTM, applied as d19c7c2791dc01d678ec017ad83868d5629b53f6.

Thank you!
Leo Famulari May 26, 2023, 5:44 p.m. UTC | #4
On Sat, May 06, 2023 at 05:16:18PM +0200, Ludovic Courtès wrote:
> Hi Leo,
> 
> The ‘cmake-build-system’ was pushed as
> 3b5b6683037dfb8f02d04ad3e6c2f04062db9a16 (a useful improvement).
> 
> The ‘ldc-bootstrap’ change LGTM!

Thanks for looking! Josselin helpfully pushed the ldc-bootstrap change
as d19c7c2791dc01d678ec017ad83868d5629b53f6
diff mbox series

Patch

diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 729d6015ae..eafc0a7bbf 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -159,7 +159,8 @@  (define ldc-bootstrap
         (base32 "1kfs4fpr1525sv2ny10hlfppy8c075vjm8m649wr2b9411pkgfzx"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f                  ;skip in the bootstrap
+     `(#:disallowed-references (,tzdata-for-tests)
+       #:tests? #f                  ;skip in the bootstrap
        #:build-type "Release"
        #:configure-flags
         (list "-GNinja")
@@ -187,7 +188,6 @@  (define ldc-bootstrap
     (inputs
      `(("libconfig" ,libconfig)
        ("libedit" ,libedit)
-       ("tzdata" ,tzdata)
        ("zlib" ,zlib)))
     (native-inputs
      `(("lld-wrapper" ,(make-lld-wrapper lld-11 #:lld-as-ld? #t))
@@ -195,6 +195,7 @@  (define ldc-bootstrap
        ("ldc" ,gdmd)
        ("ninja" ,ninja)
        ("python-wrapper" ,python-wrapper)
+       ("tzdata" ,tzdata-for-tests)
        ("unzip" ,unzip)))
     (home-page "http://wiki.dlang.org/LDC")
     (synopsis "LLVM-based compiler for the D programming language")