diff mbox series

[bug#63004,1/2] build-system/cmake: Add support for the #:disallowed-references key.

Message ID 32e4684cb2a52c963e84485e53e2680f25f2eddf.1682110198.git.leo@famulari.name
State New
Headers show
Series [bug#63004,1/2] build-system/cmake: Add support for the #:disallowed-references key. | expand

Commit Message

Leo Famulari April 21, 2023, 8:49 p.m. UTC
* guix/build-system/cmake.scm (cmake-build, cmake-cross-build):
Add #:disallowed-references.
---
 guix/build-system/cmake.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 09e3ac85db..ed979b9c6b 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -116,7 +116,8 @@  (define* (cmake-build name inputs
                       (substitutable? #t)
                       (imported-modules %cmake-build-system-modules)
                       (modules '((guix build cmake-build-system)
-                                 (guix build utils))))
+                                 (guix build utils)))
+                      disallowed-references)
   "Build SOURCE using CMAKE, and with INPUTS. This assumes that SOURCE
 provides a 'CMakeLists.txt' file as its build system."
   (define build
@@ -158,6 +159,7 @@  (define build
                       #:target #f
                       #:graft? #f
                       #:substitutable? substitutable?
+                      #:disallowed-references disallowed-references
                       #:guile-for-build guile)))
 
 
@@ -193,7 +195,8 @@  (define* (cmake-cross-build name
                             (build (nix-system->gnu-triplet system))
                             (imported-modules %cmake-build-system-modules)
                             (modules '((guix build cmake-build-system)
-                                       (guix build utils))))
+                                       (guix build utils)))
+                            disallowed-references)
   "Cross-build NAME using CMAKE for TARGET, where TARGET is a GNU triplet and
 with INPUTS.  This assumes that SOURCE provides a 'CMakeLists.txt' file as its
 build system."