diff mbox series

[bug#62310] gnu: fdroidcl: Update to 0.7.0.

Message ID 20230320225133.24860-4-sarg@sarg.org.ru
State New
Headers show
Series [bug#62310] gnu: fdroidcl: Update to 0.7.0. | expand

Commit Message

Sergey Trofimov March 20, 2023, 10:51 p.m. UTC
* gnu/packages/android.scm (fdroidcl): Update to 0.7.0.
---
 gnu/packages/android.scm | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

Comments

Maxim Cournoyer March 21, 2023, 1:58 a.m. UTC | #1
Hi!

Sergey Trofimov <sarg@sarg.org.ru> writes:

> * gnu/packages/android.scm (fdroidcl): Update to 0.7.0.
> ---
>  gnu/packages/android.scm | 20 ++++++++++----------
>  1 file changed, 10 insertions(+), 10 deletions(-)
>
> diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
> index 881b75d763..9d67dca0cd 100644
> --- a/gnu/packages/android.scm
> +++ b/gnu/packages/android.scm
> @@ -1195,25 +1195,25 @@ (define-public fdroidserver
>  (define-public fdroidcl
>    (package
>      (name "fdroidcl")
> -    (version "0.5.0")
> +    (version "0.7.0")
>      (source (origin
>                (method git-fetch)
>                (uri (git-reference
> -                     (url "https://github.com/mvdan/fdroidcl")
> -                     (commit (string-append "v" version))))
> +                    (url "https://github.com/mvdan/fdroidcl")
> +                    (commit (string-append "v" version))))
>                (file-name (git-file-name name version))
>                (sha256
> -               (base32 "1rxcdyy2j34z0ql9d62w7ivsch9xihjnpb1z9kgy9q46vl8zhhy0"))))
> +               (base32
> +                "1s3fszlyyab9gbdrg52zcbafsb1mgb770skg7b3gj7f3pzfnra5n"))))
>      (build-system go-build-system)
>      (arguments
>       `(#:import-path "mvdan.cc/fdroidcl"
> -       #:tests? #f  ; TODO: Inputs missing.
> +       #:tests? #f ;requires internet access

Perhaps, ";tests require internet access"

>         #:install-source? #f))
> -    (inputs
> -     (list go-github-com-kr-pretty))
> -    ;(native-inputs
> -    ; `(("go-github-com-rogpeppe-go-internal-testscript"
> -    ;    ,go-github-com-rogpeppe-go-internal-testscript)))
> +    (inputs (list go-github-com-kr-pretty go-github-com-schollz-progressbar-v3))
> +    ;; these are for tests, but the tests are disabled
> +    ;; (native-inputs
> +    ;; (list go-github-com-rogpeppe-go-internal go-gopkg-in-check-v1))

I think I'd remove the native-inputs completely instead of keeping dead
code around.

Thanks for the contribution!  I look forward to v2.
diff mbox series

Patch

diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 881b75d763..9d67dca0cd 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -1195,25 +1195,25 @@  (define-public fdroidserver
 (define-public fdroidcl
   (package
     (name "fdroidcl")
-    (version "0.5.0")
+    (version "0.7.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/mvdan/fdroidcl")
-                     (commit (string-append "v" version))))
+                    (url "https://github.com/mvdan/fdroidcl")
+                    (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
-               (base32 "1rxcdyy2j34z0ql9d62w7ivsch9xihjnpb1z9kgy9q46vl8zhhy0"))))
+               (base32
+                "1s3fszlyyab9gbdrg52zcbafsb1mgb770skg7b3gj7f3pzfnra5n"))))
     (build-system go-build-system)
     (arguments
      `(#:import-path "mvdan.cc/fdroidcl"
-       #:tests? #f  ; TODO: Inputs missing.
+       #:tests? #f ;requires internet access
        #:install-source? #f))
-    (inputs
-     (list go-github-com-kr-pretty))
-    ;(native-inputs
-    ; `(("go-github-com-rogpeppe-go-internal-testscript"
-    ;    ,go-github-com-rogpeppe-go-internal-testscript)))
+    (inputs (list go-github-com-kr-pretty go-github-com-schollz-progressbar-v3))
+    ;; these are for tests, but the tests are disabled
+    ;; (native-inputs
+    ;; (list go-github-com-rogpeppe-go-internal go-gopkg-in-check-v1))
     (synopsis "F-Droid desktop client")
     (description
      "While the Android client integrates with the system with regular update