diff mbox series

[bug#62310,2/4] gnu: Add go-github-com-mitchellh-colorstring.

Message ID 20230320225133.24860-2-sarg@sarg.org.ru
State New
Headers show
Series [bug#62310] gnu: fdroidcl: Update to 0.7.0. | expand

Commit Message

Sergey Trofimov March 20, 2023, 10:51 p.m. UTC
* gnu/packages/golang.scm (go-github-com-mitchellh-colorstring):
New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Maxim Cournoyer March 21, 2023, 1:47 a.m. UTC | #1
Hi!

Sergey Trofimov <sarg@sarg.org.ru> writes:

> * gnu/packages/golang.scm (go-github-com-mitchellh-colorstring):
> New variable.
> ---
>  gnu/packages/golang.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index e9187a14e9..002475093a 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -11336,6 +11336,28 @@ (define-public go-github-com-schollz-progressbar-v3
>  outputs is not provided.")
>      (license license:expat)))
>  
> +(define-public go-github-com-mitchellh-colorstring
> +  (package
> +    (name "go-github-com-mitchellh-colorstring")
> +    (version "0.0.0-20190213212951-d06e56a500db")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/mitchellh/colorstring")
> +                    (commit (go-version->git-ref version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:import-path "github.com/mitchellh/colorstring"))
> +    (home-page "https://github.com/mitchellh/colorstring")
> +    (synopsis "Functions to colorize strings for terminal output.")

Here also, the trailing period can be removed.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e9187a14e9..002475093a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11336,6 +11336,28 @@  (define-public go-github-com-schollz-progressbar-v3
 outputs is not provided.")
     (license license:expat)))
 
+(define-public go-github-com-mitchellh-colorstring
+  (package
+    (name "go-github-com-mitchellh-colorstring")
+    (version "0.0.0-20190213212951-d06e56a500db")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mitchellh/colorstring")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/mitchellh/colorstring"))
+    (home-page "https://github.com/mitchellh/colorstring")
+    (synopsis "Functions to colorize strings for terminal output.")
+    (description
+     "Colorstring provides functions for colorizing strings for terminal output.")
+    (license license:expat)))
+
 (define-public go-git-sr-ht-emersion-go-scfg
   (package
     (name "go-git-sr-ht-emersion-go-scfg")