diff mbox series

[bug#62310,3/4] gnu: Add go-github-com-k0kubun-go-ansi.

Message ID 20230320225133.24860-3-sarg@sarg.org.ru
State New
Headers show
Series [bug#62310] gnu: fdroidcl: Update to 0.7.0. | expand

Commit Message

Sergey Trofimov March 20, 2023, 10:51 p.m. UTC
* gnu/packages/golang.scm (go-github-com-k0kubun-go-ansi):
New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Maxim Cournoyer March 21, 2023, 1:55 a.m. UTC | #1
Sergey Trofimov <sarg@sarg.org.ru> writes:

> * gnu/packages/golang.scm (go-github-com-k0kubun-go-ansi):
> New variable.
> ---
>  gnu/packages/golang.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 002475093a..b831a89872 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -11358,6 +11358,28 @@ (define-public go-github-com-mitchellh-colorstring
>       "Colorstring provides functions for colorizing strings for terminal output.")
>      (license license:expat)))
>  
> +(define-public go-github-com-k0kubun-go-ansi
> +  (package
> +    (name "go-github-com-k0kubun-go-ansi")
> +    (version "0.0.0-20180517002512-3bf9e2903213")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/k0kubun/go-ansi")
> +                    (commit (go-version->git-ref version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "117afax4l268rbswf02icbgxncmd1pk2abkz7cv26iyszi8l26dq"))))
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:import-path "github.com/k0kubun/go-ansi"))
> +    (home-page "https://github.com/k0kubun/go-ansi")
> +    (synopsis "Go library for ANSI escape sequences.")

No trailing period for synopsis,

> +    (description
> +     "Windows-portable ANSI escape sequence utility for Go language")

But you need one for the description.  The project page projects a
better one, which reads "This library converts ANSI escape sequences to
Windows API calls on Windows environments." -- I'd use it for the
description.  It makes me wonder though, if it's of any use to Guix
users, since Guix is not going to produce Windows Go binaries that could
run natively on Windows... Could you test if the package that wants this
can be built without it?  It may well be optional.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 002475093a..b831a89872 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11358,6 +11358,28 @@  (define-public go-github-com-mitchellh-colorstring
      "Colorstring provides functions for colorizing strings for terminal output.")
     (license license:expat)))
 
+(define-public go-github-com-k0kubun-go-ansi
+  (package
+    (name "go-github-com-k0kubun-go-ansi")
+    (version "0.0.0-20180517002512-3bf9e2903213")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/k0kubun/go-ansi")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "117afax4l268rbswf02icbgxncmd1pk2abkz7cv26iyszi8l26dq"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/k0kubun/go-ansi"))
+    (home-page "https://github.com/k0kubun/go-ansi")
+    (synopsis "Go library for ANSI escape sequences.")
+    (description
+     "Windows-portable ANSI escape sequence utility for Go language")
+    (license license:expat)))
+
 (define-public go-git-sr-ht-emersion-go-scfg
   (package
     (name "go-git-sr-ht-emersion-go-scfg")