diff mbox series

[bug#59386,10/11] gnu: Add volk.

Message ID 20221119150248.19150-10-i@dan.games
State New
Headers show
Series Update vulkan-sdk packages to sdk-1.3.231.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail
cbaines/issue success View issue

Commit Message

dan Nov. 19, 2022, 3:02 p.m. UTC
* gnu/packages/vulkan.scm (volk): New variable.
---
 gnu/packages/vulkan.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Marius Bakke Nov. 20, 2022, 8:14 a.m. UTC | #1
dan <i@dan.games> skriver:

> * gnu/packages/vulkan.scm (volk): New variable.

[...]

> +(define-public volk
> +  (package
> +    (name "volk")
> +    (version %vulkan-sdk-version)
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url
> +                     "https://github.com/zeux/volk")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "0xaw3kg754mknx8lfj1p74a9npjfvdvlpicvn0hla4495zpc10rq"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:tests? #f     ; no test
> +       #:configure-flags (list "-DVOLK_INSTALL=ON"
> +                               "-DVOLK_PULL_IN_VULKAN=ON")))

I ran this through 'guix style' ...

> +    (inputs
> +     (list vulkan-headers))
> +    (synopsis "Meta loader for Vulkan API")
> +    (description
> +     "volk is a meta-loader for Vulkan. It allows you to dynamically load
> +entrypoints required to use Vulkan without linking to vulkan-1.dll or
> +statically linking Vulkan loader. Additionally, volk simplifies the use of
> +Vulkan extensions by automatically loading all associated
> +entrypoints. Finally, volk enables loading Vulkan entrypoints directly from
> +the driver which can increase performance by skipping loader dispatch
> +overhead.")

... and simplified the description somewhat, + added two spaces after
sentences ('guix lint' should warn about this).
diff mbox series

Patch

diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 330df898e5..0e40de0e39 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -457,3 +457,36 @@  (define-public vulkan-validationlayers
 can assist development by enabling developers to verify their applications correctly
 use the Vulkan API.")
     (license license:asl2.0)))
+
+(define-public volk
+  (package
+    (name "volk")
+    (version %vulkan-sdk-version)
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url
+                     "https://github.com/zeux/volk")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0xaw3kg754mknx8lfj1p74a9npjfvdvlpicvn0hla4495zpc10rq"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f     ; no test
+       #:configure-flags (list "-DVOLK_INSTALL=ON"
+                               "-DVOLK_PULL_IN_VULKAN=ON")))
+    (inputs
+     (list vulkan-headers))
+    (synopsis "Meta loader for Vulkan API")
+    (description
+     "volk is a meta-loader for Vulkan. It allows you to dynamically load
+entrypoints required to use Vulkan without linking to vulkan-1.dll or
+statically linking Vulkan loader. Additionally, volk simplifies the use of
+Vulkan extensions by automatically loading all associated
+entrypoints. Finally, volk enables loading Vulkan entrypoints directly from
+the driver which can increase performance by skipping loader dispatch
+overhead.")
+    (home-page "https://github.com/zeux/volk")
+    (license license:expat)))