diff mbox series

[bug#59386,11/11] gnu: Add vulkan-memory-allocator.

Message ID 20221119150248.19150-11-i@dan.games
State New
Headers show
Series Update vulkan-sdk packages to sdk-1.3.231.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail
cbaines/issue success View issue

Commit Message

dan Nov. 19, 2022, 3:02 p.m. UTC
* gnu/packages/vulkan.scm (vulkan-memory-allocator): New variable.
---
 gnu/packages/vulkan.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Marius Bakke Nov. 20, 2022, 8:24 a.m. UTC | #1
dan <i@dan.games> skriver:

> * gnu/packages/vulkan.scm (vulkan-memory-allocator): New variable.

[...]

> +(define-public vulkan-memory-allocator
> +  (package
> +    (name "vulkan-memory-allocator")
> +    (version "3.0.1")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator"
> +                    "/archive/refs/tags/v" version ".tar.gz"))

The GitHub "/archive" URLs are not stable: the tarballs are generated on
demand and cached; when the cache expires they get regenerated with
different time stamps.

Use git-fetch instead.

> +    (build-system cmake-build-system)
> +    (arguments
> +     ; no test
> +     `(#:tests? #f))
> +    (inputs
> +     (list vulkan-loader
> +           vulkan-headers))

Please run './pre-inst-env guix style vulkan-memory-allocator'.  :-)

> +    (synopsis "Easy to integrate Vulkan memory allocation library")

Just 'Vulkan memory allocation library' is sufficient.

> +    (description "Easy to integrate Vulkan memory allocation library.")

Can you turn this into a full sentence, i.e. "vulkan-memory-allocator is
an easy to integrate ...", ideally with some information about what that
means for potential users?

Can you send an updated patch?

TIA!
diff mbox series

Patch

diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 0e40de0e39..78c89af1ba 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2022 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2022 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -490,3 +491,27 @@  (define-public volk
 overhead.")
     (home-page "https://github.com/zeux/volk")
     (license license:expat)))
+
+(define-public vulkan-memory-allocator
+  (package
+    (name "vulkan-memory-allocator")
+    (version "3.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator"
+                    "/archive/refs/tags/v" version ".tar.gz"))
+              (sha256
+               (base32
+                "031nd9lrbi8j88aax94mszrx32nai8cjm061kl5m9gqh5lmpd11a"))))
+    (build-system cmake-build-system)
+    (arguments
+     ; no test
+     `(#:tests? #f))
+    (inputs
+     (list vulkan-loader
+           vulkan-headers))
+    (synopsis "Easy to integrate Vulkan memory allocation library")
+    (description "Easy to integrate Vulkan memory allocation library.")
+    (home-page "https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator")
+    (license license:expat)))