diff mbox series

[bug#56142] gnu: Add r-aseb.

Message ID 20220622135741.16618-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#56142] gnu: Add r-aseb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu June 22, 2022, 1:57 p.m. UTC
* gnu/packages/bioconductor.scm (r-aseb): New variable.
---
 gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: e74fa406e1043547242a8b67ab9907fea7aae6b9

Comments

Ricardo Wurmus Oct. 31, 2022, 8:45 p.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..f961d201d2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,32 @@  (define-public r-aneufinder
 sequencing data.")
     (license license:artistic2.0)))
 
+(define-public r-aseb
+  (package
+    (name "r-aseb")
+    (version "1.40.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "ASEB" version))
+              (sha256
+               (base32
+                "1i0r4vimk6is4j4rr14ajp8papznpmmr0bhwd96s8w53cqdqph7p"))))
+    (properties `((upstream-name . "ASEB")))
+    (build-system r-build-system)
+    (home-page "https://bioconductor.org/packages/ASEB")
+    (synopsis "Predict acetylated lysine sites")
+    (description
+     "@code{ASEB} is an R package to predict lysine sites that can be acetylated
+by a specific @dfn{KAT}-family (K-acetyl-transferases).  Lysine acetylation is
+a well-studied posttranslational modification on kinds of proteins.  About four
+thousand lysine acetylation sites and over 20 lysine KATs have been identified.
+However, which KAT is responsible for a given protein or lysine site acetylation
+is mostly unknown.  In this package, we use a @dfn{GSEA}-like (Gene Set Enrichment
+Analysis) method to make predictions.  GSEA method was developed and successfully
+used to detect coordinated expression changes and find the putative functions
+of the long non-coding RNAs.")
+    (license license:gpl3+)))
+
 (define-public r-biocversion
   (package
     (name "r-biocversion")