diff mbox series

[bug#52022] gnu: gst-plugins/selection: Fix behaviour when using flags as-is.

Message ID 3521e930d03c2eb55ee37074565d4218a28c73ad.camel@gmail.com
State Accepted
Headers show
Series [bug#52022] gnu: gst-plugins/selection: Fix behaviour when using flags as-is. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Liliana Marie Prikler Nov. 21, 2021, 5:41 p.m. UTC
When using this gst-plugins/selection without setting configure-flags, the
existing flags are simply inherited.  This leads to an issue with
unquote-splicing when looking at quoted lists, e.g. as used by
gst-plugins-bad.

* gnu/packages/gstreamer.scm (gst-plugins-selection)[#:configure-flags]:
Only splice user-provided configure-flags, simply unquote those from existing
packages.

Reported-by: unmatched-paren, nckx (IRC)
---
 gnu/packages/gstreamer.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Liliana Marie Prikler Sept. 9, 2022, 4:19 p.m. UTC | #1
Am Sonntag, dem 21.11.2021 um 18:41 +0100 schrieb Liliana Marie
Prikler:
> When using this gst-plugins/selection without setting configure-
> flags, the
> existing flags are simply inherited.  This leads to an issue with
> unquote-splicing when looking at quoted lists, e.g. as used by
> gst-plugins-bad.
> 
> * gnu/packages/gstreamer.scm (gst-plugins-selection)[#:configure-
> flags]:
> Only splice user-provided configure-flags, simply unquote those from
> existing
> packages.
> 
> Reported-by: unmatched-paren, nckx (IRC)
This patch appears rather outdated and has been superseded by one I
applied to staging.  Thus closing.
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 2927055240..f7d0808b98 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -924,13 +924,15 @@  (define-public gst-plugins/selection
     (package/inherit pkg
       (arguments
        (substitute-keyword-arguments (package-arguments pkg)
-         ((#:configure-flags flags `(,@(or configure-flags '())))
+         ((#:configure-flags flags ''())
           `(append
             (list
              ,@(map (lambda (plugin)
                       (string-append "-D" plugin "=enabled"))
                     plugins))
-            (list ,@(or configure-flags flags))))
+            ,(if configure-flags
+                 `(list ,@configure-flags)
+                 flags)))
           ((#:phases phases)
            `(modify-phases ,phases
               (add-after 'unpack 'disable-auto-plugins