diff mbox series

[bug#57092,v2,2/2] gnu: python-tox: Add native-inputs and enable tests.

Message ID 20220811054832.4849-2-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57092,v2,1/2] gnu: python-tox: Move from python-xyz.scm to python-check.scm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 11, 2022, 5:48 a.m. UTC
* gnu/packages/python-check.scm (python-tox): Add native-inputs and enable
tests.
---
 gnu/packages/python-check.scm | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)

Comments

Mathieu Othacehe Aug. 15, 2022, 9:16 a.m. UTC | #1
Hello,

> -     '(#:tests? #f))

Nice! It seems that no tests are run though, any idea why?

--8<---------------cut here---------------start------------->8---
adding license file 'LICENSE'
writing manifest file 'src/tox.egg-info/SOURCES.txt'
running build_ext

----------------------------------------------------------------------
Ran 0 tests in 0.000s

OK
--8<---------------cut here---------------end--------------->8---

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 5d6cf49c50..2a54fabd99 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2437,10 +2437,6 @@  (define-public python-tox
         (base32
          "0nk0nyzhzamcrvn0qqzzy54isxxqwdi28swml7a2ym78c3f9sqpb"))))
     (build-system python-build-system)
-    (arguments
-     ;; FIXME: Tests require pytest-timeout, which itself requires
-     ;; pytest>=2.8.0 for installation.
-     '(#:tests? #f))
     (propagated-inputs
      (list python-filelock
            python-packaging
@@ -2450,9 +2446,11 @@  (define-public python-tox
            python-toml
            python-virtualenv))
     (native-inputs
-     (list ; FIXME: Missing: ("python-pytest-timeout" ,python-pytest-timeout)
-      python-pytest ; >= 2.3.5
-      python-setuptools-scm))
+     (list python-flaky
+           python-pathlib2
+           python-pytest-timeout
+           python-pytest
+           python-setuptools-scm))
     (home-page "https://tox.readthedocs.io")
     (synopsis "Virtualenv-based automation of test activities")
     (description "Tox is a generic virtualenv management and test command line