diff mbox series

[bug#57092,v2,1/2] gnu: python-tox: Move from python-xyz.scm to python-check.scm.

Message ID 20220811054832.4849-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57092,v2,1/2] gnu: python-tox: Move from python-xyz.scm to python-check.scm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 11, 2022, 5:48 a.m. UTC
* (python-tox): Move from gnu/packages/python-xyz.scm to gnu/packages/python-check.scm.
---
 gnu/packages/python-check.scm | 37 +++++++++++++++++++++++++++++++++++
 gnu/packages/python-xyz.scm   | 37 -----------------------------------
 2 files changed, 37 insertions(+), 37 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 20ab26facf..5d6cf49c50 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2424,3 +2424,40 @@  (define-public python-pycotap
 attachments).
 @end itemize")
     (license license:expat)))
+
+(define-public python-tox
+  (package
+    (name "python-tox")
+    (version "3.20.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "tox" version))
+       (sha256
+        (base32
+         "0nk0nyzhzamcrvn0qqzzy54isxxqwdi28swml7a2ym78c3f9sqpb"))))
+    (build-system python-build-system)
+    (arguments
+     ;; FIXME: Tests require pytest-timeout, which itself requires
+     ;; pytest>=2.8.0 for installation.
+     '(#:tests? #f))
+    (propagated-inputs
+     (list python-filelock
+           python-packaging
+           python-pluggy
+           python-py
+           python-six
+           python-toml
+           python-virtualenv))
+    (native-inputs
+     (list ; FIXME: Missing: ("python-pytest-timeout" ,python-pytest-timeout)
+      python-pytest ; >= 2.3.5
+      python-setuptools-scm))
+    (home-page "https://tox.readthedocs.io")
+    (synopsis "Virtualenv-based automation of test activities")
+    (description "Tox is a generic virtualenv management and test command line
+tool.  It can be used to check that a package installs correctly with
+different Python versions and interpreters, or run tests in each type of
+supported environment, or act as a frontend to continuous integration
+servers.")
+    (license license:expat)))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f6b986d4e8..b049cded13 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14739,43 +14739,6 @@  (define-public python-deprecation
 that deprecated code is eventually removed.")
     (license license:asl2.0)))
 
-(define-public python-tox
-  (package
-    (name "python-tox")
-    (version "3.20.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "tox" version))
-       (sha256
-        (base32
-         "0nk0nyzhzamcrvn0qqzzy54isxxqwdi28swml7a2ym78c3f9sqpb"))))
-    (build-system python-build-system)
-    (arguments
-     ;; FIXME: Tests require pytest-timeout, which itself requires
-     ;; pytest>=2.8.0 for installation.
-     '(#:tests? #f))
-    (propagated-inputs
-     (list python-filelock
-           python-packaging
-           python-pluggy
-           python-py
-           python-six
-           python-toml
-           python-virtualenv))
-    (native-inputs
-     (list ; FIXME: Missing: ("python-pytest-timeout" ,python-pytest-timeout)
-           python-pytest ; >= 2.3.5
-           python-setuptools-scm))
-    (home-page "https://tox.readthedocs.io")
-    (synopsis "Virtualenv-based automation of test activities")
-    (description "Tox is a generic virtualenv management and test command line
-tool.  It can be used to check that a package installs correctly with
-different Python versions and interpreters, or run tests in each type of
-supported environment, or act as a frontend to continuous integration
-servers.")
-    (license license:expat)))
-
 (define-public python-jmespath
   (package
    (name "python-jmespath")