diff mbox series

[bug#55637] gnu: Add python-progress.

Message ID 29380d8edaa09ee05fa7525107aa95063c108793.1653677770.git.peter@polidoro.io
State Accepted
Headers show
Series [bug#55637] gnu: Add python-progress. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro May 27, 2022, 6:57 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-progress): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Ludovic Courtès June 6, 2022, 8:21 p.m. UTC | #1
peter@polidoro.io skribis:

> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/python-xyz.scm (python-progress): New variable.

Applied, thanks!

Please open a new issue if there are followup patches.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44eeb0d7fe..d226ff94b5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15226,6 +15226,25 @@  (define-public python-promise
      "Promises/A+ implementation for Python")
     (license license:expat)))
 
+(define-public python-progress
+  (package
+    (name "python-progress")
+    (version "1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "progress" version))
+       (sha256
+        (base32 "1k9lpb7lqr6mywpnqcz71y6qny54xlgprdp327za2gy0nnc6xj69"))))
+    (build-system python-build-system)
+    (home-page "http://github.com/verigak/progress/")
+    (synopsis "Progress reporting bars for Python")
+    (description "This Python package provides progress reporting for visual
+of progress of long running operations.  There are multiple choices of
+progress bars and spinners, with customizable options, such as width, fill
+character, and suffix.")
+    (license license:isc)))
+
 (define-public python-progressbar2
   (package
     (name "python-progressbar2")