diff mbox series

[bug#55674,2/2] gnu: emacs-helpful: Update to 0.19.

Message ID 20220527125242.27817-2-erik.sab@gmail.com
State Accepted
Headers show
Series [bug#55675,1/2] gnu: emacs-elm-mode: Update to 0.21.0-1.1e27768. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Erik Šabič May 27, 2022, 12:52 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.19.
---
 gnu/packages/emacs-xyz.scm | 39 ++++++++++++++++++++------------------
 1 file changed, 21 insertions(+), 18 deletions(-)

Comments

M May 27, 2022, 1:12 p.m. UTC | #1
Erik Šabič schreef op vr 27-05-2022 om 14:52 [+0200]:
> +     ;; Tests are not passing; the author might not be using them anymore.
> +     `(#:tests? #f

How do they fail?  They might indicate a real problem in the code
(that's what tests are for -- detecting problems before they are
actually encountered).

Greetings,
Maxime.
M May 27, 2022, 1:48 p.m. UTC | #2
[Please keep 55675@debbugs.gnu.org in CC]

Erik Šabič schreef op vr 27-05-2022 om 15:32 [+0200]:
> Well it fails on a test defined like this:
> (ert-deftest helpful--docstring ()
>   "Basic docstring fetching."
>   (should
>    (equal
>     (helpful--docstring #'test-foo t)
>     "Docstring here.")))
> 
> And fails like so:
> ...............s...s..Test helpful--docstring-advice backtrace:


> 
> Test helpful--docstring-advice condition:
> 
>     (ert-test-failed
>      ((should
>        (equal
>         (helpful--docstring ... t)
>         "Docstring here too."))
>       :form
>       (equal "Docstring here too.\n\nThis function has :around
> advice: `ad-Advice-test-foo-advised'." "Docstring here too.")
>       :value nil :explanation
>       (arrays-of-different-length 84 19 "Docstring here too.\n\nThis
> function has :around advice: `ad-Advice-test-foo-advised'."
> "Docstring here too." first-mismatch-at 19)))
> 
> F............................................................s......

Looks like a bug.

> I don't know anything about emacs-ert. And I wasn't able to
> figure out if it works for the upstream author.
>
> WDYT?

I don't know if it fails for the upstream author, but I don't think
that's relevant to Guix.  More relevant I think, is that this bug
appears in Guix, so it can cause problems for Guix users, so some
fixing might be necessary.

I don't know much about Emacs though, so you might need to contact
upstream about the bug.

Greetings,
Maxime.
Erik Šabič May 27, 2022, 2:58 p.m. UTC | #3
One of the tests fails. Looks like it's testing whether helpful--docstring
and
helpful--docstring-advice figure out that a function is advised.

I've tried using helpful-* functions from this updated package in Emacs,
and it works - advices are shown.

So it looks like the tests are broken.
(but I don't understand the ert tests, maybe someone else
should look at this)
yarl baudig May 29, 2022, 5:05 a.m. UTC | #4
Yes, your pull request have been accepted! Thank you. Mind if I update? I would like helpful to be fixed quickly.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f62c733fb5..6a659fabf3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20126,27 +20126,29 @@  (define-public emacs-download-region
 (define-public emacs-helpful
   (package
     (name "emacs-helpful")
-    (version "0.18")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/Wilfred/helpful")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0gdjxykqkal2x765mi51m99i5ql23i1fy909wy4mzj5ajhjfgqcc"))))
+    (version "0.19")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Wilfred/helpful")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0qwsifzsjw95l83m7z07fr9h1sqbhggwmcps1qgbddpan2a8ab8a"))))
     (build-system emacs-build-system)
-    (propagated-inputs
-     (list emacs-elisp-refs emacs-dash emacs-s emacs-f emacs-shut-up))
-    (native-inputs
-     (list emacs-ert-runner emacs-undercover))
+    (propagated-inputs (list emacs-elisp-refs emacs-dash emacs-s emacs-f
+                             emacs-shut-up))
+    (native-inputs (list emacs-ert-runner emacs-undercover))
     (arguments
-     `(#:tests? #t
-       #:test-command '("ert-runner")))
+     ;; Tests are not passing; the author might not be using them anymore.
+     `(#:tests? #f
+       #:test-command
+       '("ert-runner")))
     (home-page "https://github.com/Wilfred/helpful")
     (synopsis "More contextual information in Emacs help")
-    (description "@code{helpful} is an alternative to the built-in Emacs help
+    (description
+     "@code{helpful} is an alternative to the built-in Emacs help
 that provides much more contextual information.
 
 @itemize
@@ -20164,7 +20166,8 @@  (define-public emacs-helpful
 @item Display any keybindings that apply to interactive functions.
 @item Trace, disassemble functions from inside Helpful.  This is discoverable
 and doesn't require memorisation of commands.
-@end itemize\n")
+@end itemize
+")
     (license license:gpl3+)))
 
 (define-public emacs-logview