diff mbox series

[bug#55675,1/2] gnu: emacs-elm-mode: Update to 0.21.0-1.1e27768.

Message ID 20220527125242.27817-1-erik.sab@gmail.com
State Accepted
Headers show
Series [bug#55675,1/2] gnu: emacs-elm-mode: Update to 0.21.0-1.1e27768. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Erik Šabič May 27, 2022, 12:52 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-elm-mode): Update to 0.21.0-1.1e27768.
---
 gnu/packages/emacs-xyz.scm | 43 +++++++++++++++++++-------------------
 1 file changed, 22 insertions(+), 21 deletions(-)


base-commit: d37c7f7ad4134cc15d1558eb6c0bc4c59a0db1af

Comments

Erik Šabič May 27, 2022, 1:21 p.m. UTC | #1
I forgot to mention the removal of emacs-dash from propagated-inputs.

These are two unrelated updates in a patchset. I didn't know git send-email
would do this automatically. Is this okay? Or should I have submitted them
separately?

Thank you!
M May 27, 2022, 1:49 p.m. UTC | #2
Erik Šabič schreef op vr 27-05-2022 om 15:21 [+0200]:
> These are two unrelated updates in a patchset. I didn't know git
> send-email would do this automatically.

"git send-email" just sends the commits you made, it is up to the user
to split the commits appropriately, it doesn't do any cleanups.

> Is this okay? Or should I have submitted them

Depends, is it actually an unrelated change?  Why is emacs-dash
removed?

Greetings,
Maxime.
Erik Šabič May 27, 2022, 2:27 p.m. UTC | #3
Elm-mode dropped the usage of dash.el in favor of seq.el

Merged upstream with commit:
70734a1eed6f008135c197e115ca5f197e47ee0b

Author:     Steve Purcell <steve@sanityinc.com>
AuthorDate: Mon Feb 21 05:57:33 2022 +1300
Ludovic Courtès June 5, 2022, 9:34 p.m. UTC | #4
Hi Erik,

Erik Šabič <erik.sab@gmail.com> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-elm-mode): Update to 0.21.0-1.1e27768.

It has been updated to 0.22 in the meantime.

Thank you,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f7fb6aac35..f62c733fb5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19692,26 +19692,27 @@  (define-public emacs-ibuffer-vc
     (license license:gpl3+)))
 
 (define-public emacs-elm-mode
-  (package
-    (name "emacs-elm-mode")
-    (version "0.21.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-        (git-reference
-         (url "https://github.com/jcollard/elm-mode")
-         (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0iwk4fmw8hq3ry4ky1zc7lgl4cpbnrjyk74c2xzddfspi3ks41fd"))))
-    (propagated-inputs
-     (list emacs-dash emacs-f emacs-reformatter emacs-s))
-    (build-system emacs-build-system)
-    (home-page "https://github.com/jcollard/elm-mode")
-    (synopsis "Emacs major mode for editing Elm source code")
-    (description
-     "This package provides a major mode for editing Elm source code, and
+  ;; Version tag 0.21.0 was made Jan 14 2020. It doesn't work with Emacs 28
+  ;; due to missing, now-mandatory "when" arg for obsolete function alias.
+  (let ((commit "1e277684d8a6681a2410cce2dd589ee30a998369"))
+    (package
+      (name "emacs-elm-mode")
+      (version (git-version "0.21.0" "1" commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jcollard/elm-mode")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1gnr61ibzcznfqy5f8capmbz75rcfikwy106rjdmp45qz2jwp4di"))))
+      (propagated-inputs (list emacs-f emacs-reformatter emacs-s))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/jcollard/elm-mode")
+      (synopsis "Emacs major mode for editing Elm source code")
+      (description
+       "This package provides a major mode for editing Elm source code, and
 working with common core and third-party Elm tools.  Its features are:
 
 @itemize
@@ -19725,7 +19726,7 @@  (define-public emacs-elm-mode
 @item Integration with elm-format
 @item Integration with elm-test
 @end itemize")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-helm-mode-manager
   (package