diff mbox series

[bug#55637] gnu: Add python-progress.

Message ID a6c3edc9de69547f10d1a288ecc79c1c9916f662.1653499938.git.peter@polidoro.io
State Accepted
Headers show
Series [bug#55637] gnu: Add python-progress. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro May 25, 2022, 5:33 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-progress): New variable.
---
 gnu/packages/python-xyz.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Christopher Baines May 27, 2022, 9:24 a.m. UTC | #1
peter@polidoro.io writes:

> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/python-xyz.scm (python-progress): New variable.
> ---
>  gnu/packages/python-xyz.scm | 16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 35a2009f69..a9fbfcc2f4 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -31764,3 +31764,19 @@ (define-public python-canopen
>  simple Pythonic interface. It is mainly targeted for testing and automation
>  tasks rather than a standard compliant master implementation.")
>      (license license:expat)))
> +
> +(define-public python-progress
> +  (package
> +    (name "python-progress")
> +    (version "1.6")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "progress" version))
> +       (sha256
> +        (base32 "1k9lpb7lqr6mywpnqcz71y6qny54xlgprdp327za2gy0nnc6xj69"))))
> +    (build-system python-build-system)
> +    (home-page "http://github.com/verigak/progress/")
> +    (synopsis "Progress reporting bars for Python")
> +    (description "Progress reporting bars for Python")
> +    (license license:isc)))

The description looks like it could be improved here, plus same comment
about not adding new package definitions to the bottom of files.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 35a2009f69..a9fbfcc2f4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31764,3 +31764,19 @@  (define-public python-canopen
 simple Pythonic interface. It is mainly targeted for testing and automation
 tasks rather than a standard compliant master implementation.")
     (license license:expat)))
+
+(define-public python-progress
+  (package
+    (name "python-progress")
+    (version "1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "progress" version))
+       (sha256
+        (base32 "1k9lpb7lqr6mywpnqcz71y6qny54xlgprdp327za2gy0nnc6xj69"))))
+    (build-system python-build-system)
+    (home-page "http://github.com/verigak/progress/")
+    (synopsis "Progress reporting bars for Python")
+    (description "Progress reporting bars for Python")
+    (license license:isc)))