diff mbox series

[bug#55637] gnu: Add python-canopen.

Message ID 5fbd41490624bfb900d276f616be21edaadf724a.1653498609.git.peter@polidoro.io
State Accepted
Headers show
Series [bug#55637] gnu: Add python-canopen. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro May 25, 2022, 5:11 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-canopen): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Christopher Baines May 27, 2022, 9:22 a.m. UTC | #1
peter@polidoro.io writes:

> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/python-xyz.scm (python-canopen): New variable.
> ---
>  gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 6ca759e2e2..35a2009f69 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -31743,3 +31743,24 @@ (define-public python-preshed
>       "Simple but high performance Cython hash table mapping pre-randomized keys
>  to void* values.")
>      (license license:expat)))
> +
> +(define-public python-canopen
> +  (package
> +    (name "python-canopen")
> +    (version "2.0.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "canopen" version))
> +       (sha256
> +        (base32 "1nb543wb37kj95v6bhh272lm5gkpi41q3pnsl1fxlyizm2gamj5w"))))
> +    (build-system python-build-system)
> +    (native-inputs (list python-packaging))
> +    (propagated-inputs (list python-can))
> +    (home-page "")
> +    (synopsis "CANopen stack implementation")
> +    (description "A Python implementation of the CANopen standard. The aim of
> +the project is to support the most common parts of the CiA 301 standard in a
> +simple Pythonic interface. It is mainly targeted for testing and automation
> +tasks rather than a standard compliant master implementation.")
> +    (license license:expat)))

The linter picks up a couple of issues:

gnu/packages/python-xyz.scm:31761:17: python-canopen@2.0.0: sentences in description should be followed by two spaces; possible infractions at 47, 162
gnu/packages/python-xyz.scm:31759:15: python-canopen@2.0.0: invalid home page URL: ""

Plus, I'd avoid adding packages to the end of modules. If everyone does
this, it means lots of git conflicts. Instead, try and slot the new
package definition in somewhere close to related packages, or
alphabetically, or randomly even if neither of those approaches apply.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6ca759e2e2..35a2009f69 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31743,3 +31743,24 @@  (define-public python-preshed
      "Simple but high performance Cython hash table mapping pre-randomized keys
 to void* values.")
     (license license:expat)))
+
+(define-public python-canopen
+  (package
+    (name "python-canopen")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "canopen" version))
+       (sha256
+        (base32 "1nb543wb37kj95v6bhh272lm5gkpi41q3pnsl1fxlyizm2gamj5w"))))
+    (build-system python-build-system)
+    (native-inputs (list python-packaging))
+    (propagated-inputs (list python-can))
+    (home-page "")
+    (synopsis "CANopen stack implementation")
+    (description "A Python implementation of the CANopen standard. The aim of
+the project is to support the most common parts of the CiA 301 standard in a
+simple Pythonic interface. It is mainly targeted for testing and automation
+tasks rather than a standard compliant master implementation.")
+    (license license:expat)))